Your IP:

Our Forums Have Moved!

Visit our new forums at http://community.opendns.com/forums/ to post on topics and read the latest content. These forums are now read-only archives.

K-12 Forums

Talk with other K-12 network administrators in your state.

Or see all states.

Categories

Vanilla 1.1.4 is a product of Lussumo. More Information: Documentation, Community Support.

This discussion has been inactive for longer than 30 days, and is thus closed.
    • CommentAuthortpprynn
    • CommentTimeJun 20th 2011
     permalink
    I've been using OpenDNS nearly three years but it's only recently that I am finding myself blocked from too many sites, harmless ones too. Is it something to do with Firefox 4 possibly? I can't see an option to disable DNS prefetching if that would help. Sometimes when I'm online a site will be accessible, other times not. Vimeo is an example. I don't really want to have to manually unblock each site, and haven't learnt the procedure for that yet anyway, but I use mobile Broadband with 3 in the UK and OpenDNS gives me almost double speed it seems at times, so I'm not keen to forego OpenDNS.

    All advice welcome. Thanks.
    • CommentAuthorRed Prince
    • CommentTimeJun 20th 2011
     permalink
    Is your IP address current in your dashboard? OpenDNS does not just blocking sites at a whim, it has to be asked to.
    • CommentAuthorrotblitz
    • CommentTimeJun 20th 2011 edited
     permalink
    "I am finding myself blocked from too many sites"

    How exactly does this look like? Are you landing at a block page like this?
    http://block.opendns.com/?url=www.example.com&ablock=

    If not, it is not your OpenDNS settings blocking you, but something else.

    "Is it something to do with Firefox 4 possibly? I can't see an option to disable DNS prefetching if that would help."

    Not sure if DNS prefetching has any influence on blocking, but if so, you normally shouldn't become aware of it.

    If you want to disable DNS prefetching:
    1. Enter "about:config" in the address line, and confirm the warning.
    2. Filter by "dns.disable".
    3. Change (or add) the values of the two parameters to "true".
    network.dns.disablePrefetch = true
    network.dns.disablePrefetchFromHTTPS = true
    (If you can't find these values, simply add them.)

    "Vimeo is an example."

    Fine. So post the text output of the following commands here, and we will take a look:
    (Trailing dots are part of the command!)
    nslookup -tpye=txt debug.opendns.com.
    nslookup vimeo.com.

    "I use mobile Broadband with 3 in the UK..."

    Really? And you're using OpenDNS at all? http://welcome.opendns.com/
    • CommentAuthortpprynn
    • CommentTimeJun 21st 2011
     permalink
    Hello, thanks for the replies. At this address

    http://ubuntuone.com/p/10VU/

    you can see a .png image file I've placed there of what I saw just now when I tried ot go to Vimeo. At that point the url read:

    http://block.opendns.com/main?url=8774787080156880781686796877707866857083746677&ablock=&nref=

    Apologies that I neglected to mention I'm mostly online with Ubuntu Linux 11.04 rather than my Windows 7 laptop, although the issue is present there too. So I'm not sure if the output of a Linux terminal will be what you're after when using those commands. It says:

    xxx@xxx-pc:/$ nslookup -tpye=txt debug.opendns.com.
    *** Invalid option: tpye=txt
    Server: 208.67.222.222
    Address: 208.67.222.222#53

    ** server can't find debug.opendns.com.: NXDOMAIN

    xxx@xxx-pc:/$ nslookup vimeo.com.
    Server: 208.67.222.222
    Address: 208.67.222.222#53

    Non-authoritative answer:
    Name: vimeo.com
    Address: 74.113.233.128

    xxx@xxx-pc:/$

    I think possibly 3 Mobile Broadband in particular and maybe the other companies may have had to drop their Mobile Broadband service altogether if not for OpenDNS, as until the recent increase in blocking I've seen it brought a dramatic improvement and is spoken about in all the fury-filled forums, e.g. Vodafone's.

    Hope you can be of further help based on what I've told you. Thanks very much for so far.
  1.  permalink
    nslookup vimeo.com.
    Server: 208.67.222.222
    Address: 208.67.222.222#53

    Non-authoritative answer:
    Name: vimeo.com
    Address: 74.113.233.128

    That is not blocked. That's the address for Vimeo, so you must have a block page cached in your browser, or the block page address cached in your local resolver cache.

    Otherwise, to avoid excess blocking, configure your filtering settings at your Dashboard appropriately. You can always find out under what categories a domain will be be blocked: http://www.opendns.com/support/checker/

    Further, you must run an Updater. Right now, check to make sure your IP is correct at your Network Dashboard, that the Network IP matches the one shown at the very top of the pages at this site.

    nslookup -tpye=txt debug.opendns.com.
    *** Invalid option: tpye=txt
    Server: 208.67.222.222
    Address: 208.67.222.222#53

    ** server can't find debug.opendns.com.: NXDOMAIN

    Typo. Try again.:wink:

    For a Unix-like OS, you would use Dig instead of Nslookup.
    • CommentAuthorrotblitz
    • CommentTimeJun 21st 2011 edited
     permalink
    "*** Invalid option: tpye=txt"

    Yes, try again:
    nslookup -type=txt debug.opendns.com.     (not tpye!)

    And 74.113.233.128 is the correct address of vimeo.com, not an OpenDNS address, so it is not blocked, unless your browser uses a different DNS service than your OS.

    Under Linux try also this:
    dig debug.opendns.com txt
    dig vimeo.com
    • CommentAuthortpprynn
    • CommentTimeJun 22nd 2011
     permalink
    All seems well now, whether through following advice here or changing the apn from three.co.uk to 3internet - I'm posting this in case someone has the same issue.

    Thanks for your help.
  2.  permalink
    Not sure how changing the APN would change any OpenDNS blocking if you were being blocked too much. That just selects your service provider.

This discussion has been inactive for longer than 30 days, and is thus closed.