Your IP:

Our Forums Have Moved!

Visit our new forums at http://community.opendns.com/forums/ to post on topics and read the latest content. These forums are now read-only archives.

K-12 Forums

Talk with other K-12 network administrators in your state.

Or see all states.

Categories

Vanilla 1.1.4 is a product of Lussumo. More Information: Documentation, Community Support.

This discussion has been inactive for longer than 30 days, and is thus closed.
    • CommentAuthorlobster70
    • CommentTimeSep 6th 2011
     permalink
    I've searched thoroughly and I'm fairly tech-savvy yet I cannot find the answer to my question. My networking knowledge isn't particularly robust but I can usually figure things out with trial and error if nothing else. I have found similar questions here in the forums but the answers don't seem to match reality for me.

    Some background: I have an ASUS WL-520GU router running DD-WRT firmware. I have configured two static DNS on the router (208.67.222.222 and 208.67.220.220) and set my OpenDNS account to the desired Web Content Filtering level. I have also installed OpenDNS Updater on my Windows PC since my ISP assigns IPs dynamically. On the PC, everything works perfectly. I'm quite thrilled with it, in fact.

    However, "mobile" devices such as iPod Touch and Android phones do not appear to be restricted by the OpenDNS Web Content Filtering setting. Pages which are NOT permitted on the PC will load on my child's iPod, for example. I also tried hitting welcome.opendns.com and it appears that the iPod is not going through the router as expected.

    How can this be? The iPod is most definitely accessing the network through the router just like the PC. How is the iPod bypassing OpenDNS??

    I did see that the DSL modem also has DNS settings. They are currently set as Dynamic, but I assume that's irrelevant since the router sits between the modem and the iPod.

    Everything has been rebooted for good measure. What am I missing here?

    One thing I suspect but don't fully understand on my router setting page is DNSmasq. There are checkboxes for "DNSMasq with DHCP" and also "with DNS." From what I can tell, this is something that is helpful on a small home network. Is that the source of my problem with iPod? (And if so, why not the PC?)

    Thanks for any light you can shed...

    Eric
    • CommentAuthorrotblitz
    • CommentTimeSep 6th 2011
     permalink
    Do you see more than two DNS server fields in DD-WRT? If yes, fill them all. Additional addresses are 208.67.220.222 and 208.67.222.220.

    "it appears that the iPod is not going through the router as expected."

    Do your mobile devices really use this/your router, or may they have been connected to an unprotected router in the neighborhood? Check the WLAN SSID on these devices after having ensured that your SSID is really unique too. Configure their network settings to explicitly connect to your router (using your SSID). Possibly configure them manually, not automatically.

    Also, check at this occasion that the DNS server settings are set to obtain them automatically (via DHCP from the router), or set it explicitly to the IP address of your router. No other external DNS server addresses must be present.

    "One thing I suspect but don't fully understand on my router setting page is DNSmasq."

    You may not need DNSmasq now.
    http://thekelleys.org.uk/dnsmasq/doc.html
    Thankful People: burtenshaw
    • CommentAuthorlobster70
    • CommentTimeSep 7th 2011
     permalink
    There are three fields, the third was blank. It may be defaulting to somewhere outside of OpenDNS...? (Still doesn't explain the difference between PC and iPod.) But I just changed it by filling in the third field as suggested. I will test.

    I am absolutely certain of the following:
    1. iPod is connecting only to my network
    2. WLAN SSID is in fact my own, which is unique and requires a password
    3. The iPods have been manually configured
    4. There are no open wireless networks within reach of my home

    DNS server setting in the iPod was set automatically and is the IP address of the router. I tried setting it to an OpenDNS IP just for kicks and no pages would load. I changed it back, explicitly setting it to the router IP address again.

    I had seen that page about DNSmasq. I will try without to see what I get.

    After I've had a chance to test this with the third DNS filled in, I will report back.

    Thanks!
  1.  permalink
    "There are three fields, the third was blank. It may be defaulting to somewhere outside of OpenDNS...?"

    Absolutely. Always fill all fields. Don't forget to flush browser and local resolver caches afterward.
    • CommentAuthorlobster70
    • CommentTimeSep 7th 2011
     permalink
    That was it! It would be helpful to include this tidbit in the generic router instructions. Better yet, add a DD-WRT instruction page! The importance of NOT leaving one of the fields blank is not intuitive. Also, the existence of the additional DNS addresses 208.67.220.222 and 208.67.222.220 don't seem to be easy to discover.
    Thankful People: maintenance, padres
    • CommentAuthorrotblitz
    • CommentTimeSep 7th 2011 edited
     permalink
    Here is one: http://www.dd-wrt.com/wiki/index.php/OpenDNS
    However, regarding the third DNS field it is not quite right. Someone may amend it.
    The author apparently wasn't aware of the additional IP addresses either...
    • CommentAuthorlobster70
    • CommentTimeSep 7th 2011
     permalink
    Thanks. I was thinking more along the lines of having a DD-WRT icon on this page: https://store.opendns.com/setup/router/
    (Or maybe a link to the dd-wrt page in the "For the nerds" section.)
    • CommentAuthorrotblitz
    • CommentTimeSep 7th 2011
     permalink
    Good idea! We users like you can't do much for you DD-WRT users, however.
    • CommentAuthormaintenance
    • CommentTimeSep 7th 2011 edited
     permalink
    "That was it! It would be helpful to include this tidbit in the generic router instructions."

    The additional addresses should really be on every page, most especially the generic instructions page, as is done, e.g., for the Linksys page.

    I am really happy that the cache-flushing instruction links were added to all the setup pages. It was great when that was added. I'd have to say that the KB is, if anything, more difficult to use than prior to its redesign.
    Thankful People: rotblitz
    • CommentAuthorlobster70
    • CommentTimeSep 8th 2011
     permalink
    The DD-WRT Wiki has been updated to include this info.
    Thankful People: rotblitz
    • CommentAuthorrotblitz
    • CommentTimeSep 8th 2011
     permalink
    Brilliant!
  2.  permalink
    I'm having a related problem with my network. I have a Belkin N1 router. There are 2 fields for DNS settings, which are set to the two addresses listed at the bottom of OpenDNS pages. All three computers are successfully blocked, as is the Safari on my iPod Touch. The strange thing is that the Opera mobile browser seems to be not blocked at all. How can this be?
  3.  permalink
    Opera? Uses a proxy. Turn off "Turbo Mode".
    Thankful People: graculuswatkins
  4.  permalink
    Oh, as easy as that! Thanks! Though I guess that means it's vulnerable to someone turning it back on again.

    So why does it use a proxy? And why does it work, given that my OpenDNS settings are supposed to prevent proxies/anonymizers?
  5.  permalink
    "So why does it use a proxy?"

    To give you Turbo. Opera serves pages directly from its own web cache servers.

    "And why does it work, given that my OpenDNS settings are supposed to prevent proxies/anonymizers? "

    Because it is a network setting (in the browser, in this case) and not a web page. Allow anyone to change network settings on a computer, or install software, and they can use something other than OpenDNS as well.
    Thankful People: graculuswatkins
    • CommentAuthorrotblitz
    • CommentTimeSep 26th 2011
     permalink
    http://www.opera.com/browser/turbo/
    http://www.opera.com/support/usingopera/operaini/
    One may be able to freeze the turbo mode setting with turbosettings.xml - to off.
    Thankful People: maintenance

This discussion has been inactive for longer than 30 days, and is thus closed.