Your IP:

Our Forums Have Moved!

Visit our new forums at http://community.opendns.com/forums/ to post on topics and read the latest content. These forums are now read-only archives.

K-12 Forums

Talk with other K-12 network administrators in your state.

Or see all states.

Categories

Vanilla 1.1.4 is a product of Lussumo. More Information: Documentation, Community Support.

This discussion has been inactive for longer than 30 days, and is thus closed.
    • CommentAuthorjadonb
    • CommentTimeMay 3rd 2012
     permalink
    set everything up via router, dlink dir-615

    ipconfig /all

    Microsoft Windows [Version 6.1.7601]
    Copyright (c) 2009 Microsoft Corporation. All rights reserved.

    C:\Users\jadon>ipconfig /all

    Windows IP Configuration

    Host Name . . . . . . . . . . . . : jadon-Laptop
    Primary Dns Suffix . . . . . . . :
    Node Type . . . . . . . . . . . . : Hybrid
    IP Routing Enabled. . . . . . . . : No
    WINS Proxy Enabled. . . . . . . . : No
    DNS Suffix Search List. . . . . . : hsd1.or.comcast.net.

    Ethernet adapter Local Area Connection 2:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : TAP-Win32 Adapter V9
    Physical Address. . . . . . . . . : 00-FF-5B-7D-76-44
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes

    Wireless LAN adapter Wireless Network Connection:

    Connection-specific DNS Suffix . : hsd1.or.comcast.net.
    Description . . . . . . . . . . . : Realtek RTL8187B Wireless 802.11b/g 54Mbp
    s USB 2.0 Network Adapter
    Physical Address. . . . . . . . . : 00-16-44-9F-F0-15
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    Link-local IPv6 Address . . . . . : fe80::b0dc:5d8d:e676:b9bc%11(Preferred)
    IPv4 Address. . . . . . . . . . . : 192.168.0.103(Preferred)
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Lease Obtained. . . . . . . . . . : Thursday, May 03, 2012 6:01:20 AM
    Lease Expires . . . . . . . . . . : Thursday, May 10, 2012 6:01:24 AM
    Default Gateway . . . . . . . . . : 192.168.0.1
    DHCP Server . . . . . . . . . . . : 192.168.0.1
    DHCPv6 IAID . . . . . . . . . . . : 218109508
    DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-16-9F-97-2A-00-A0-D1-9F-3B-EB

    DNS Servers . . . . . . . . . . . : 192.168.0.1
    NetBIOS over Tcpip. . . . . . . . : Enabled

    Ethernet adapter Local Area Connection:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Marvell Yukon 88E8039 PCI-E Fast Ethernet
    Controller
    Physical Address. . . . . . . . . : 00-A0-D1-9F-3B-EB
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter isatap.hsd1.or.comcast.net.:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . : hsd1.or.comcast.net.
    Description . . . . . . . . . . . : Microsoft ISATAP Adapter
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Teredo Tunneling Pseudo-Interface:

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes
    IPv6 Address. . . . . . . . . . . : 2001:0:4137:9e76:3827:356e:b396:7fe5(Pref
    erred)
    Link-local IPv6 Address . . . . . : fe80::3827:356e:b396:7fe5%22(Preferred)
    Default Gateway . . . . . . . . . : ::
    NetBIOS over Tcpip. . . . . . . . : Disabled

    C:\Users\jadon>
    • CommentAuthorrotblitz
    • CommentTimeMay 3rd 2012
     permalink
    Your ipconfig looks good. What does http://welcome.opendns.com/ show up with?

    If "Oops!", see if your ISP redirects your DNS lookups to their DNS service:
    (Trailing dot is part of the command!)
    nslookup -type=txt which.opendns.com.
    nslookup -type=txt which.opendns.com. 208.67.222.222
    Thankful People: krauserelli
    • CommentAuthorjadonb
    • CommentTimeMay 3rd 2012
     permalink
    the 2 snlookups return the respective text
    "i am not an openDNS resolver"
    "2.sea"
    • CommentAuthorrotblitz
    • CommentTimeMay 3rd 2012
     permalink
    I see. The configuration of the OpenDNS server addresses on your router is wrong.
    Check again: https://store.opendns.com/setup/device/dlink-dir-615
    • CommentAuthoredmgt
    • CommentTimeMay 3rd 2012
     permalink
    Familiar situation on my side. I have a buffalo router and one day opendns says you're using it, another day it's says no, you aren't using it. How's that possible!?
    • CommentAuthorrotblitz
    • CommentTimeMay 3rd 2012
     permalink
    Nice of you to break with a Buffalo router into this D-Link related thread. This is what we were waiting for! :angry:

    Whatever, maybe you have more than two slots for DNS server addresses, but filled only two?
    • CommentAuthorzeroram
    • CommentTimeMay 3rd 2012
     permalink
    hi im a new user of open dns! my prob is i dont know where do i get the needed ip address on add network pls advise thanks a lot :-D
    • CommentAuthorzeroram
    • CommentTimeMay 3rd 2012
     permalink
    pls i will waite till some one advise me so i can use my account use full thanks :-D
    • CommentAuthoredmgt
    • CommentTimeMay 3rd 2012
     permalink
    rotblitz, sorry, i didn't want to be rude. And for the number of slots for dns i think yes, i have one more: https://i.minus.com/i1QLMu9TF5dzC.PNG
  1.  permalink
    More than one, fill them all: 208.67.222.220 208.67.220.222

    Where do you find your public IP to add as a network? Well, one place to see it is under the OpenDNS logo on nearly every page on this site where it says "Your IP: xxx.xxx.xxx.xxx".
    • CommentAuthorjadonb
    • CommentTimeMay 3rd 2012 edited
     permalink
    this is what my router DNS is now http://imgur.com/PcF1l

    i have gone through the setup multiple times using the shows DNS and the standard openDNS as shown above ^

    also the ISP is comcast
    if i set the DNS on computer it works (but this is not a solution)
    i need the router to force openDNS for the whole network
    • CommentAuthorrotblitz
    • CommentTimeMay 3rd 2012
     permalink
    Hmm, something seems to be broken with your router.
    http://support.dlink.com/emulators/dir615_revB/221/WAN.html

    If you go to the status page, what DNS addresses does it show?
    http://support.dlink.com/emulators/dir615_revB/221/Device_Info.html

    Btw, you have selected "Dynamic IP (DHCP)" as internet connection type. This is rather unusual. You may want to try with PPPoE and "Dynamic IP", but you would need a username and password for this kind of internet access from your ISP. If you have, try it out!
    • CommentAuthorjadonb
    • CommentTimeMay 3rd 2012
     permalink
    status page shows dns as
    Primary DNS Server : 208.67.222.123
    Secondary DNS Server : 208.67.220.123
    Advanced DNS : Disabled

    also the firmware is of a newer version (3.x) than the example (2.x)

    if it helps the router is fed via Tx100 cat5 from a Comcast cable modem
    • CommentAuthorjadonb
    • CommentTimeMay 3rd 2012
     permalink
    i disabled DNS relay in the router and then my laptop could not communicate with a DNS server
  2.  permalink
    "i disabled DNS relay in the router and then my laptop could not communicate with a DNS server "

    Then you have no external DNS server IPs on the computer, but just the LAN IP of the router. [[DNS Servers : 192.168.0.1]] This is normal. (Although I swear I had run into a router a couple years back where this was reversed.)

    I would see about rotblitz's suggestion regarding the WAN connection type. Also, comcast may serve your DNS queries regardless, but maybe there is a way to opt out. Some Comcast customers do have their DNS redirected - and apparently if you use the Constant Guard software from Comcast, you DNS will also be redirected. See here:
    https://forums.opendns.com/comments.php?DiscussionID=12561#Item_38 and below.

    "i need the router to force openDNS for the whole network "

    The DNS on local machines takes precedence over the router unless you set router firewall rules.
    • CommentAuthorjadonb
    • CommentTimeMay 4th 2012
     permalink
    i am in a webchat now to have comcast DNS opt-out

    will see if that works

    ill firewall the dns later
    • CommentAuthorrotblitz
    • CommentTimeMay 4th 2012
     permalink
    "Advanced DNS : Disabled"

    You may also try with enabling this.
    • CommentAuthorjadonb
    • CommentTimeMay 4th 2012
     permalink
    if i do that then it grays out the areas to enter a DNS adress
    • CommentAuthorrotblitz
    • CommentTimeMay 4th 2012
     permalink
    What have been the results out of the Comcast webchat?

    Did you consult D-Link support features? I would think this is the point to do so, because this seems to be a router problem, static DNS server addresses not taking effect. So not much to do with OpenDNS.
    • CommentAuthorjadonb
    • CommentTimeMay 5th 2012
     permalink
    comcast said i was already opt-out of DNS

    dlink support features?

    i will poke about with static IP settings
  3.  permalink
    Only if you can set DNS only to static will this work. Otherwise you end up with no connection to the ISP.

    I would suggest, at this point, that you unplug the router for a few minutes until the capacitors full discharge, plug it back in, and see what happens. Failing that, I would try resetting the router, then re-configuring the OpenDNS addresses. If that fails as well, you should check with D-Link support. In my limited experience, the 615 was always a good, solid, configurable router which worked well for many people.
    • CommentAuthorrotblitz
    • CommentTimeMay 5th 2012
     permalink
    "dlink support features?"

    Yeah, sure! What else? http://www.dlink.com/support/default.aspx

This discussion has been inactive for longer than 30 days, and is thus closed.