Your IP:

Our Forums Have Moved!

Visit our new forums at http://community.opendns.com/forums/ to post on topics and read the latest content. These forums are now read-only archives.

K-12 Forums

Talk with other K-12 network administrators in your state.

Or see all states.

Categories

Vanilla 1.1.4 is a product of Lussumo. More Information: Documentation, Community Support.

This discussion has been inactive for longer than 30 days, and is thus closed.
  1.  permalink
    My network printer connects to the network via a USB server which plugs into a Billion 6404VGP router. The router's DHCP table shows the printer with a MAC address (00:24:32:01:ae:8b) and IP address (192.168.1.2). The USB server came with software to permit a controllable connection to the printer, and if this connection is chosen, the printer works OK, however the printer is then unavailable to anyone else on the network until it's disconnected. A second piece of supplied software (Network Printer Wizard) permits the printer to be available even in the disconnected state to all networked users, by using the MAC address assigned to the printer.
    Before changing the router to OpenDNS, this worked fine (old DNS IPs were 61.9.211.1 and 61.9.211.33), but now it no longer works - the print job just stays in the print queue until it is deleted or gives a "failed to print" error message. When setting up the Network Printer Wizard, it can see the MAC addressed printer - it just won't print to it. Any ideas?
    • CommentAuthorrotblitz
    • CommentTimeMay 10th 2012
     permalink
    Sure, every idea!
    http://www.opendns.com/support/article/27
    Click "Domain Typos, VPN and filtering .cm Wildcard".
  2.  permalink
    Thanks for the reply. I've tried carefully following the instructions in this Support Article, however it's not clear what domain to use. Every one I try returns an "Invalid domain" message. This includes the Home network IP, the Router IP, the Network Server IP, the printer's MAC address and 127.0.0.1. I've also tried changing my filtering level to "Nothing blocked", again without success.
  3.  permalink
    "This includes the Home network IP, the Router IP, the Network Server IP, the printer's MAC address and 127.0.0.1."

    None of those are domain or network names. Use the full printer name as ythe network sees it, including any DNS suffixes added by your ISP.

    "I've also tried changing my filtering level to "Nothing blocked", again without success. "

    This has nothing to do with filtering, so no.
    • CommentAuthorrotblitz
    • CommentTimeMay 11th 2012
     permalink
    "it's not clear what domain to use."

    If you check your domain stats, you'll see them.

    "Every one I try returns an "Invalid domain" message."

    IP addresses are not domains and do not use DNS. Therefore they are irrelevant.
  4.  permalink
    Thanks for the responses. I've tried using the full printer name as seen by the network (LPR_Samsung-ML-1860-Series-00243201ae8b.dcp.515.e8040c33) and while the setting was accepted (ie. I didn't get an "Invalid domain name" error message), it still has not solved the problem. Thanks anyway.
  5.  permalink
    Two points:
    1) You must always flush your local resolver cache after changing any setting, or the old data persists.
    2) You must make sure to use the full network name, so in the case your ISP sets a DNS suffix, that must either be removed or you must add the suffix to the (printer) name.

    You may find this in Stats or by doing
    ipconfig /all
    or you may also detect it doing nslookup for a domain without using a trailing dot, if it exists.
    • CommentAuthorrotblitz
    • CommentTimeMay 14th 2012
     permalink
    "it still has not solved the problem."

    Then you did not enter the domain name OpenDNS sees from you for your printer.
    As said, check your stats, and you will find it there.
  6.  permalink
    Thanks - I checked the stats and used the domain name of the printer from that list and applied it. I also flushed the DNS cache. The problem is now solved and the printer works without having to be specifically connected to a particular computer. Many thanks.
    • CommentAuthorrotblitz
    • CommentTimeMay 14th 2012
     permalink
    Sure, this is what I said 3 days ago already...

This discussion has been inactive for longer than 30 days, and is thus closed.