Your IP:

Our Forums Have Moved!

Visit our new forums at http://community.opendns.com/forums/ to post on topics and read the latest content. These forums are now read-only archives.

K-12 Forums

Talk with other K-12 network administrators in your state.

Or see all states.

Categories

Vanilla 1.1.4 is a product of Lussumo. More Information: Documentation, Community Support.

This discussion has been inactive for longer than 30 days, and is thus closed.
  1.  permalink
    We have a strange quirk with Google search on our network. This is only happening to a few of our users.

    Our clients have Windows 7 with Internet Explorer 8 installed, with the Search Box in the top corner set to Google.

    If the user uses this search box the page fails to load and eventually times out. If they go directly to www.google.com and perform the search it works fine. The problem only occurs when using the search box.

    I thought this problem was IE related, but I have noticed that this problem also occurs on my computer with Google Chrome. If I search by typing in the Chrome address bar the page fails to load and times out. Oddly if I have "Instant for faster searching" enabled the "live" search seems to work, but if I press enter, the search fails to complete.

    I have no idea what might be causing this, but I suspect maybe its an OpenDNS problem with validating the re-routing?

    Any ideas appreciated
    • CommentAuthorrotblitz
    • CommentTimeMay 17th 2012
     permalink
    Are you saying you have this problem only when using OpenDNS?

    "maybe its an OpenDNS problem with validating the re-routing?"

    Uh, no, a DNS service is never involved in any re-routing. DNS is in name resolution.
  2.  permalink
    Yes I realise that, but if for example I go to www.google.com, it automatically takes me to www.google.co.uk (because I am in the UK).

    Correct me if I am wrong, but I thought OpenDNS's cache was responsible for this action?

    Maybe re-routing is the wrong term.
  3.  permalink
    Routing is a physical network thing, so yes, that generally would be the wrong term.

    What any resolver does, whether from its cache or a lookup (which is how it got into the cache in the first place), is get the address from the domain's authoritative nameserver. So you ask OpenDNS "where is google.com"?, and OpenDNS gives you one of the IP addresses for that domain that the NS gives the resolver (which varies in the internet topology, which is only somewhat tightly coupled to geography).

    Your browser then connects to that IP, and Google redirects you to a different domain name from their server, which gets looked up again. This can actually be pretty complex, and google.com and google.co.uk probably share IP addresses, etc.

    It's even further complicated if you actually use www.google.com, which is a CNAME for www.l.google.com...

    But in any case, Google is responsible for all of it.

    None of this has anything to do with the browser issue. :bigsmile:

    The problem here is that the search box is doing what the browser vendor wanted it to do, which may break in some circumstances. And Chrome would be not such a good comparison, as it is possibly more controlled by the vendor than even IE.

    So the diagnostic question stands: Is this something you experience only when using OpenDNS?
    Thankful People: rotblitz, Red Prince
  4.  permalink
    Thanks for the explanation, it is very helpful.

    How can I test changing OpenDNS on an isolated computer?

    We have a sonicwall NSA device which holds the open DNS settings but I dont really want to make changes for all our users for testing. Is it it possible to make the changes locally on one PC to force it use a different DNS provider?
  5.  permalink
    Sure. Computer DNS settings always take precedence over the router settings, so changing the DNS on one computer, then clearing the caches, would do it.

    However, this depends on what rules might be set in the Sonicwall. If any other DNS server is blocked or DNS requests are redirected at the Sonicwall, then no, unless you can make exceptions for the particular workstation.

    But to phrase the original question more broadly and explicitly,
    - Did you just switch to OpenDNS or not?
    - Did this problem just start happening, or is it old?
    - Was the appearance of this problem coincident with starting use of OpenDNS?
    Thankful People: rotblitz
  6.  permalink
    to answer your three questions:

    - No, we have been using OpenDNs for quite a while now
    - It first happened to a couple of users a few weeks ago, now a few more have mentioned it
    - No, the appearance of this problem did not seem to coincide with us starting to use OpenDNS
  7.  permalink
    This rather tends to confirm what is already suspected since only a few machines in your network experience the issue (and no one else is reporting the problem), that this is configuration-specific to these browsers or workstations, and generally unrelated to OpenDNS.

    First try the browsers in safe/no add-ons mode, and if that doesn't help, reset the browser configuration.

    Let us know how you get on with changing the DNS settings if you can do that once at an afflicted computer.

    Aside: Does Chrome even have a separate search box these days, or is it unified with the address bar? What about your IE version? They seem to go back and forth on this.
  8.  permalink
    Hi Maintenance,

    You are correct, Chrome does not have a separate search box, but I have experienced this when attempting to search in the main address box.

    I think you are correct that it might be a browser setting, its just strange that the problem started occurring without any changes.

    I will try what you say though regarding disabling all the add ons etc
    • CommentAuthorrotblitz
    • CommentTimeMay 18th 2012
     permalink
    "its just strange that the problem started occurring without any changes."

    No changes? Windows changes its settings quite often. Just run regmon and filemon, and you'll see. You not changing anything doesn't mean there were not dozens or hundreds of changes in between...
  9.  permalink
    It looks like I have the fix for this.

    By changing the following two registry keys

    [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\SearchScopes\{FFA9E331-CBF0-4E9D-BD22-3178F80BF47F}]

    (that big long string will be unique to the user but will be the one that refers to Google)

    SuggestionsURL (change the "google.com" part to "google.co.uk")
    URL (change the "google.com" part to "google.co.uk")
    Thankful People: rotblitz, maintenance

This discussion has been inactive for longer than 30 days, and is thus closed.