Your IP:

Our Forums Have Moved!

Visit our new forums at http://community.opendns.com/forums/ to post on topics and read the latest content. These forums are now read-only archives.

K-12 Forums

Talk with other K-12 network administrators in your state.

Or see all states.

Categories

Vanilla 1.1.4 is a product of Lussumo. More Information: Documentation, Community Support.

This discussion has been inactive for longer than 30 days, and is thus closed.
    • CommentAuthorhydroguy
    • CommentTimeJul 26th 2012
     permalink
    I have a D Link router and have set the DNS server addresses it in, but it is not working. OpenDNS is not working for me. I can set the server addresses for my computer and that works, but not working network wide by the router. I have followed the configuration instructions as found on this site.
    Would appreciate any suggestions.

    Ronnie
  1.  permalink
    Hi, Have you tried to flush the DNS cache?
    • CommentAuthorhydroguy
    • CommentTimeJul 27th 2012 edited
     permalink
    Yes I have done that, but that is done at the PC level. The problem is in the router settings.
  2.  permalink
    And the DNS entries for each network device are either blank, or contain your router's IP address... OK?
    • CommentAuthorhydroguy
    • CommentTimeJul 27th 2012
     permalink
    I don't quite understand this, but here is what I did. In my DSL modem, the DNS servers were blank, I changed that to the Open DNS server addresses. Then I removed the DNS server addresses from the router, making them blank.
    When I run the ipconfig /all check on a PC it returns this for the DNS Servers: fac0:0:0:ffff::1x1 and fac0:0:0:ffff::2x1 but now Open DNS is working for me.
    • CommentAuthorrotblitz
    • CommentTimeJul 27th 2012
     permalink
    "it returns this for the DNS Servers: fac0:0:0:ffff::1x1 and fac0:0:0:ffff::2x1"

    These are IPv6 resolvers. I'm not even sure if these are valid DNS resolvers. There *must* be also at least one IPv4 resolver address, ideally your router's.

    Best is to copy & paste the complete plain text output of "ipconfig /all" here, so we can take a look.
    • CommentAuthorhydroguy
    • CommentTimeJul 27th 2012
     permalink
    Here is what I get: I did misread some of the info. in the previous post.

    C:\Users\Ronnie Collins>ipconfig /all

    Windows IP Configuration

    Host Name . . . . . . . . . . . . : RonnieCollins
    Primary Dns Suffix . . . . . . . :
    Node Type . . . . . . . . . . . . : Hybrid
    IP Routing Enabled. . . . . . . . : No
    WINS Proxy Enabled. . . . . . . . : No

    Ethernet adapter Network Card:

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Realtek PCI GBE Family Controller
    Physical Address. . . . . . . . . : 00-0A-CD-19-2D-82
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    Link-local IPv6 Address . . . . . : fe80::49ba:4221:6577:59a4%18(Preferred)
    IPv4 Address. . . . . . . . . . . : 192.168.0.103(Preferred)
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Lease Obtained. . . . . . . . . . : Friday, July 27, 2012 9:12:41 AM
    Lease Expires . . . . . . . . . . : Friday, August 03, 2012 9:12:41 AM
    Default Gateway . . . . . . . . . : 192.168.0.1
    DHCP Server . . . . . . . . . . . : 192.168.0.1
    DHCPv6 IAID . . . . . . . . . . . : 385878733
    DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-10-09-53-57-00-1E-8C-A4-09-F3

    DNS Servers . . . . . . . . . . . : 192.168.0.1
    NetBIOS over Tcpip. . . . . . . . : Enabled

    Ethernet adapter Network on MB:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : NVIDIA nForce 10/100/1000 Mbps Ethernet
    Physical Address. . . . . . . . . : 00-1E-8C-A4-09-F3
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes

    Ethernet adapter Local Area Connection:

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : VMware Virtual Ethernet Adapter for VMnet
    1
    Physical Address. . . . . . . . . : 00-50-56-C0-00-01
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    Link-local IPv6 Address . . . . . : fe80::7d5b:8f06:59c4:52c1%20(Preferred)
    IPv4 Address. . . . . . . . . . . : 192.168.72.1(Preferred)
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Lease Obtained. . . . . . . . . . : Thursday, July 19, 2012 8:37:32 AM
    Lease Expires . . . . . . . . . . : Friday, July 27, 2012 12:22:45 PM
    Default Gateway . . . . . . . . . :
    DHCP Server . . . . . . . . . . . : 192.168.72.254
    DHCPv6 IAID . . . . . . . . . . . : 453005398
    DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-10-09-53-57-00-1E-8C-A4-09-F3

    DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
    fec0:0:0:ffff::2%1
    fec0:0:0:ffff::3%1
    NetBIOS over Tcpip. . . . . . . . : Enabled

    Ethernet adapter Local Area Connection 5:

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : VMware Virtual Ethernet Adapter for VMnet
    8
    Physical Address. . . . . . . . . : 00-50-56-C0-00-08
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    Link-local IPv6 Address . . . . . : fe80::98c0:dc6:22a7:5dc%22(Preferred)
    IPv4 Address. . . . . . . . . . . : 192.168.48.1(Preferred)
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Lease Obtained. . . . . . . . . . : Thursday, July 19, 2012 8:37:33 AM
    Lease Expires . . . . . . . . . . : Friday, July 27, 2012 12:22:39 PM
    Default Gateway . . . . . . . . . :
    DHCP Server . . . . . . . . . . . : 192.168.48.254
    DHCPv6 IAID . . . . . . . . . . . : 486559830
    DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-10-09-53-57-00-1E-8C-A4-09-F3

    DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
    fec0:0:0:ffff::2%1
    fec0:0:0:ffff::3%1
    Primary WINS Server . . . . . . . : 192.168.48.2
    NetBIOS over Tcpip. . . . . . . . : Enabled
    • CommentAuthorrotblitz
    • CommentTimeJul 27th 2012
     permalink
    Ah yes, your active IPv4 DNS indeed points to your router at 192.168.0.1, and unlike you say, it has no IPv6 resolvers configured.

    So we must look at the router again.
    Was your router on this list? https://store.opendns.com/setup/router/D-Link

    Only if not, what exact D-Link model and FW version do you have? Ideally also post a link to an online manual and/or emulator of this router.
    • CommentAuthorhydroguy
    • CommentTimeJul 27th 2012
     permalink
    Yes, my router is the DIR 615, FW 3.13NA
    • CommentAuthorrotblitz
    • CommentTimeJul 27th 2012
     permalink
    So, you followed these instructions? https://store.opendns.com/setup/device/dlink-dir-615
    And it doesn't work with this, i.e. http://welcome.opendns.com/ returns "Oops"? It should work!

    Post the complete output of the following command (trailing dot is part of it):
    nslookup -type=txt which.opendns.com.
    • CommentAuthorhydroguy
    • CommentTimeJul 27th 2012
     permalink
    Yes, I setup the router exactly like those instructions show. It does not work, I get the Oops Message when testing. I would add a picture file, but I see no way to do that.

    Here is the output you asked for.
    ***************************************************************
    C:\Users\Ronnie Collins>nslookup -type=txt which.opendns.com
    Server: UnKnown
    Address: 192.168.0.1

    Non-authoritative answer:
    which.opendns.com text =

    "I am not an OpenDNS resolver."
    ***************************************************************
    The only way I have found to make it work is to put the OpenDNS server addresses in my modem.

    Thanks for your help.
    • CommentAuthorrotblitz
    • CommentTimeJul 27th 2012
     permalink
    "I am not an OpenDNS resolver."

    Your router does not send your lookups to OpenDNS. :sad:
    It seems to be somehow broken. Did you ensure you have the latest firmware installed? Did you search D-Link or router specific forums for similar problems?

    "The only way I have found to make it work is to put the OpenDNS server addresses in my modem."

    Ok, if it works well this way, go for this.
    • CommentAuthorhydroguy
    • CommentTimeJul 27th 2012
     permalink
    It does seem that my router is not working correctly. I do have the latest firmware for it. I will see if D Link can provide any assistance.

    thanks again
  3.  permalink
    Either this, or your modem redirects DNS lookups.
    • CommentAuthorecmsi
    • CommentTimeAug 1st 2012
     permalink
    modem is handing out DHCP to your router. You need to put your modem in bridge mode the set your router as your DHCP server and put your DSL info in your router. Then place the OpenDNS in the DHCP info as well. This will resolve your issue.
    • CommentAuthorbreagha
    • CommentTimeAug 1st 2012
     permalink
    How does one set a modem to bridge mode?
    • CommentAuthorrotblitz
    • CommentTimeAug 1st 2012
     permalink
    One accesses the (unspecified) modem's admin interface, logs in, and change the operating mode from "NAT/router" to "bridged". How else? :wink:
    Or maybe the modem has an external switch for this? Difficult to say without having this modem on the desk...
    • CommentAuthorahnelson
    • CommentTimeAug 8th 2012
     permalink
    @hydro guy:

    This problem started in firmware 3.13 or 3.12 (don't recall). Backpedal the firmware to 3.12(3.11) and all will be well.

    I had played with this one day, with the exact same results. I tried dd-wrt for a while but it is quite unstable for this model. I re-flashed back to 3.13 forgetting about this problem, and will likely be flashing back to 3.12/3.11 tonight.

    good luck.

This discussion has been inactive for longer than 30 days, and is thus closed.