Your IP:

Our Forums Have Moved!

Visit our new forums at http://community.opendns.com/forums/ to post on topics and read the latest content. These forums are now read-only archives.

K-12 Forums

Talk with other K-12 network administrators in your state.

Or see all states.

Categories

Vanilla 1.1.4 is a product of Lussumo. More Information: Documentation, Community Support.

This discussion has been inactive for longer than 30 days, and is thus closed.
  1.  permalink
    I've been using internet with no problem at home at at coffee shops, but when I went to the library and used its free wifi, every other site I wanted to go to was blocked. I can't check email, go onto game sites, humor sites, facebook, or anything.

    I've checked my installed programs list, and it's not installed without my knowledge.

    In nslookup.exe I typed the command 'which.opendns.com' and got:

    Server: resolver1.opendns.com
    Adress: 208.67.222.222

    Non-authoritative answer:
    Name: which.opendns.com.public.co.[HOME-COUNTY].va.us
    Address: 67.215.65.132

    I feel like I'm good enough at computers, but I've been trying to fix this for hours, and nothing's working. I've also done a virus check, and it's come clean.
  2.  permalink
    And it's not the library's filtering, which redirects to a different site, and they only do proxies and gambling things. Not hotmail and facebook.
  3.  permalink
    Nevermind. The problem became fixed. When I find out how it was done, I'll post it here.
    • CommentAuthorrotblitz
    • CommentTimeSep 15th 2012 edited
     permalink
    First mistake was that you didn't type "nslookup -type=txt which opendns.com.", but "nslookup which.opendns.com" instead, i.e. without the -type parameter and without trailing dot. This resolved then a non-existent fake name which.opendns.com.public.co.[HOME-COUNTY].va.us for you.

    At least it was OpenDNS which resolved this for you:

    "Server: resolver1.opendns.com
    Adress: 208.67.222.222"

    because 67.215.65.132 is hit-nxdomain.opendns.com.

    "I've checked my installed programs list, and it's not installed without my knowledge."

    OpenDNS isn't installed anyway, it is not software, and you cannot download it, but it is a configurable online service.

    There are exactly two possibilities you're using OpenDNS in this scenario:

    1. The library has configured OpenDNS as their DNS resolvers, and your laptop gets it via DHCP.
    2. The OpenDNS resolver addresses have been entered into your laptop's network configuration.

    Edit: Ha, funny, "opendnsglitchvictim"! You'll soon have regrets because of this nonsense.
  4.  permalink
    OpenDNS iz in ur netwerkz, eatin ur dohmane lookupz.

    The only way it ever gets there, as rotblitz notes, is if someone put it there, or the network you are using has it configured. Contrary to much popular imagination, OpenDNS cannot reach out of the intartubes and redirect DNS traffic to their servers.

    ipconfig /all
    may be helpful - try it when you see OpenDNS filtering.

    Also, when you leave the network where you experience this, or remove the addresses from manual network config, flush your browser and local resolver caches or you will be faced with further "blocking" from your own caches.
    • CommentAuthorrotblitz
    • CommentTimeSep 15th 2012
     permalink
    Ha, he said "I feel like I'm good enough at computers", so why the efforts. He knows all of this. :wink:
  5.  permalink
    So the problem came back when I went back to the library, but I was able to find out how it was fixed before.

    I clicked on the list of wireless connections, right clicked on the active network and selected "Status."

    At the bottom there's a button that says "Properties". Under the Networking tab there's a box under the words "This connection uses the following items." Under that click once the text that says "Internet Protocol Version 4 (TCP/IPv4)". Now the button that says "Properties" will become able to be selected. After you click on it, look for the option that says "Obtain DNS server automatically" and select it. Click apply, and you're good to go.
    • CommentAuthorrotblitz
    • CommentTimeSep 18th 2012
     permalink
    Yeah, this should be the normal state for roaming devices. So, what was it else, before you changed it?

This discussion has been inactive for longer than 30 days, and is thus closed.