Your IP:

Our Forums Have Moved!

Visit our new forums at http://community.opendns.com/forums/ to post on topics and read the latest content. These forums are now read-only archives.

K-12 Forums

Talk with other K-12 network administrators in your state.

Or see all states.

Categories

Vanilla 1.1.4 is a product of Lussumo. More Information: Documentation, Community Support.

This discussion has been inactive for longer than 30 days, and is thus closed.
    • CommentAuthorbharr
    • CommentTimeNov 13th 2012 edited
     permalink
    Several people including myself have started getting a popup from the network icon in the system tray after today's (11/13/12) Windows update that reads "Additional log on information may be required. Click to open your browser". It seems that the two things we all have in common is that we all use Windows 7 and Open DNS. Does the staff or anyone have any ideas as to what may be causing this?
    The main items that were updated were .Net framework 4 and security updates including one for IE9.
    • CommentAuthorcraig_k
    • CommentTimeNov 13th 2012
     permalink
    Same issue here. Same setup. Win7 and OpenDNS.
  1.  permalink
    Same here. Just for the heck of it, switched out DNS provider to another and problem went away. Not sure what it is, but I do know, Win7 (and possibly above) looks for the following domains when starting up for network location awareness:

    dns.msftncsi.com
    www.msftncsi.com

    Running Windows 7 x64
  2.  permalink
    Ditto.
    • CommentAuthorcharlieo
    • CommentTimeNov 13th 2012
     permalink
    Same here. Windows 7 X64. Authenticate to a domain via ethernet too.

    Everything still works properly after 11/13/12 Windows Update, but the pop-ups are driving me nuts!

    Switched to Comcast DNS server (75.75.75.75) and the error disapears. Hate to lose my paid OpenDNS account.......

    What gives?
    • CommentAuthoruscjnet
    • CommentTimeNov 13th 2012 edited
     permalink
    Same here. Open DNS setup on router (WNDR3700v1). Installed today's updates on two systems - one hard-wired to the router and another that connects via WiFi.

    After the updates, the annoying and inexplicable "Additional log on ..." message kept popping up.

    Switched DNS setting on router to "auto retrieve from provider" and messages magically disappeared. Bizarre. Hope there is a fix soon!

    Haven't tried it yet ... but I am curious if I went back and now re-entered the OpenDNS info on the router, if the problem would return (or if resetting somehow clears something out). Will try that experiment later when the family isn't online.
    • CommentAuthorbharr
    • CommentTimeNov 13th 2012
     permalink
    Tell the family "tough". IT people want to know! ;)
    • CommentAuthorgotroot
    • CommentTimeNov 13th 2012
     permalink
    This may have something to do with Windows 7's (along with 2008R2 from my testing) Network Connectivity Status Indicator service:

    http://blog.superuser.com/2011/05/16/windows-7-network-awareness/

    It seems that when your machine tries to connect to either dns.msftncsi.com or www.msftncsi.com upon start-up and detects something in the way (like a paywall, captive portal, proxy, etc.), it throws up that "additional logon..." balloon. Something with one of today's patches changed something and somehow gets affected by users behind OpenDNS (this doesn't happen to me using Google's public DNS servers or my IPSs DNS servers).

    Using that page above, I temporarily disabled the "EnableActiveProbing" key, rebooted and did not receive that annoying bubble while still safely using OpenDNS's systems. There is a gotcha though and your machine may not think it's connected to the Internet at all after disabling that probe, YMMV. Either way, while I do not recommend anyone change their registry because of the possible damage to one's PC taking such measures, I was able to use OpenDNS's servers after this update without that annoying pop-up making that registry change. Naturally, after this is fixed, I'll be re-enabling the probe to return my PC to it's native functionality.
    • CommentAuthorcoredump
    • CommentTimeNov 13th 2012
     permalink
    I updated 4 machines with the latest MSFT patches and started getting this annoying popup on every one of them. Thanks to gotroot, the problem is solved for now...
    • CommentAuthoruscjnet
    • CommentTimeNov 13th 2012 edited
     permalink
    Thanks gotroot for the article/hack. But, I have 5 systems running Win 7 or 8 and really do not want to have to change the registry setting on each system (and then remember to revert!).

    I submitted a ticket to OpenDNS. I have not seen anything about this yet on MS forums. This is pretty strange ...
    • CommentAuthoruscjnet
    • CommentTimeNov 13th 2012
     permalink
    Just received this response from OpenDNS:

    Sorry to hear that you're having issues. I just read through both forum posts, and while somebody did post a registry fix in the Seven Forums thread, I'm wondering if a setting in your OpenDNS account is causing the issue. So far, it's sounding like this problem may be caused by the NXDOMAIN redirection setting being enabled for your network.

    In order to resolve this, please log into the Dashboard and select Settings. After that, select your network, and then choose "Customization" in the left-hand menu. You will be brought to a page that you will allow you to toggle the "Enabled NX Domain Redirection" option. Please disable that option.

    After that, flush your DNS resolver cache and web browser cache on each device to ensure that your new DNS configuration settings take effect immediately. Instructions to clear your DNS resolver cache can be found here: http://www.opendns.com/support/article/68, and instructions to clear your web browser cache can be found here: http://www.opendns.com/support/article/67.

    Once you do that, please see if the Additional Logon balloon disappears. Will you let me know how it goes?
    • CommentAuthorkiuma
    • CommentTimeNov 13th 2012 edited
     permalink
    • CommentAuthorzelus
    • CommentTimeNov 13th 2012 edited
     permalink
    Hello everyone,

    We're currently investigating this issue, and aim to have a solution ready shortly.

    We appreciate and thank you for your patience regarding this matter.
    • CommentAuthoruscjnet
    • CommentTimeNov 13th 2012
     permalink
    zelus ... can you comment on my posting above, which is an email I received from one of your techs in response to my ticket. Thanks.
    • CommentAuthortomazyk
    • CommentTimeNov 13th 2012
     permalink
    Removing update KB2750841 resolves the problem. http://support.microsoft.com/kb/2750841
    • CommentAuthorrockshox
    • CommentTimeNov 13th 2012 edited
     permalink
    It looks like the patch adds IPv6 support to the Microsoft Network Connectivity Status Indicator (NCSI). I'm assuming that the error is in regards to the IPv6 trying to probe the network connection and failing.

    The patch adds a key under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NlaSvc\Parameters\Internet for ActiveWebProbHostV6, ActiveWebProbePathV6, ActiveWebProbeContentV6 etc..
    • CommentAuthorrockshox
    • CommentTimeNov 13th 2012 edited
     permalink
    The problem is that OpenDNS can't resolve http://ipv6.msftncsi.com/ncsi.txt or any of the other checks that the NCSI uses to detect a live internet connection and then redirects to the OpenDNS Website Unavailable page.
    • CommentAuthorcharlieo
    • CommentTimeNov 13th 2012
     permalink
    Unticking the NXDOMAIN redirection in the control panel does IN FACT solve the problem (i.e. the pop-ups stop). Re-enabled EnableActiveProbing in the registry, etc. Flushed DNS and re-booted.

    So, what are we now missing by NOT using NXDOMAIN redirection? Should we care?

    Thanks!

    Charlie
    Thankful People: interkan.net, uscjnet
    • CommentAuthorhetchi
    • CommentTimeNov 13th 2012
     permalink
    Same problem on my end, hopefully gets a fix soon.
    • CommentAuthortimmywa
    • CommentTimeNov 13th 2012
     permalink
    Seems more like a band-aid not a resolution. Why limit our functionality? I'm waiting for a fix from the gurus here at OpenDNS!
    • CommentAuthoruscjnet
    • CommentTimeNov 13th 2012
     permalink
    I can confirm that unchecking the "NXDomain" option under customization seems to have done the trick. I have reset my router with OpenDNS settings after disabling NXDomain and the "Additional Log On ..." pop us has not popped up. Will update later if any changes.
    • CommentAuthormrgames2
    • CommentTimeNov 14th 2012
     permalink
    I do not have this setting under customization. Is this a paid user thing? What do I do> Use something else?
    • CommentAuthortimmywa
    • CommentTimeNov 14th 2012
     permalink
    mrgames2: Dashboard > Settings > Choose Network > Advanced Settings:
    Enable typo correction (and NX Domain redirection)
    Fixes common typos (like typing google.cmo instead of google.com) on the fly. (Uncheck this option)
    • CommentAuthormrgames2
    • CommentTimeNov 14th 2012 edited
     permalink
    Thank you. I hope we are notified by email when this is fixed?
  3.  permalink
    I tried to apply this fix, but my OpenDNS settings tells me I don't have a network!
    So I tried to add one (I have a static IP), but it tells me that it already exists!!!

    What do I do ?
    TIA, Dave
    • CommentAuthordaled
    • CommentTimeNov 14th 2012 edited
     permalink
    The problem with unchecking "Enable type correction (and NX Domain redirection)" is that is also disables the web content filtering. So if you want to filter out certain categories of web sites (like adware or porn) you can no longer have OpenDNS do so. That is one of the main reasons that I use OpenDNS. Hopefully this is just a bandaid and OpenDNS will fix it correctly so Content filtering does not need to be disabled.
    • CommentAuthoruscjnet
    • CommentTimeNov 14th 2012
     permalink
    daled -- I don't think unchecking NXDomain will affect web content filtering. Does not seem to have had the impact for me.
    • CommentAuthormwg1998
    • CommentTimeNov 14th 2012
     permalink
    I have the same issue. Windows 7, OpenDNS, Windows XP Virtual PC installed.
    • CommentAuthordaled
    • CommentTimeNov 14th 2012 edited
     permalink
    uscjnet: When I unchecked the box, a red warning came up saying that web content filtering required the option. When I unchecked and saved the option, my web content filtering was disabled. If I try to enable web content filtering again, I'm told I need first to enable typo correction. I do not have a paying account. I wonder if that makes difference?
    • CommentAuthorzoze009
    • CommentTimeNov 14th 2012
     permalink
    You can also suppress the notification balloons by pressing the "show hidden icons" arrow on the left end of the Windows system tray, clicking on "Customize", then setting the "Network" icon to "Hide icon and notifications". This avoids messing with the registry and, as far as I can tell, does not affect OpenDNS features.
    • CommentAuthorgeekpryde
    • CommentTimeNov 14th 2012
     permalink
    Same issues here. Win7 x64, OpenDNS user, running OpenDNS Updater 2.2.1. This little problem has even got the attention of Brian Krebs at krebsonsecurity.com. I am NOT going to suppress the pop-up, so I know when OpenDNS actually gets it fixed. We'll see how long I can hold out...
    • CommentAuthoruscjnet
    • CommentTimeNov 14th 2012
     permalink
    daled: I do have a paid account (OpenDNS VIP). When I unchecked "NXDomain," I had no warnings. Only the "Guide Page" options were greyed out. I did email tech support with your question. I will post here when I hear back.
    • CommentAuthorjohnjces
    • CommentTimeNov 14th 2012
     permalink
    I searched my OpenDNS Dashboard, go to Customization and "Enabled NX Domain Redirection" option is nowhere to be found. I can upload a logo, do a guidepage but no redirection.

    Pretty annoying.
    • CommentAuthordaled
    • CommentTimeNov 14th 2012
     permalink
    uscjnet: Thanks. On my screen, NXDomain and typo correction are the same check box. I just have the free home account.
    • CommentAuthorraybo4
    • CommentTimeNov 14th 2012
     permalink
    Windows 2008 R2 has the same issues as do the Windows 7 boxes. Cheers!
  4.  permalink
    kb2750841 is the update that causes opendns users to see that pop up. I have uninstalled it, or in computers that haven't yet been updated I am hiding the update until they get this sorted out. What a PITA.
    • CommentAuthorjgsouthard
    • CommentTimeNov 14th 2012
     permalink
    On a free home OpenDNS account, it appears that the NXDomain redirection setting is under Dashboard > Settings > <select a network> > Advanced Settings > Domain Typos. If you DISABLE "Enable typo correction (and NX Domain redirection)" (which also disables Web Content Filtering) then the popups go away.

    But at least on my system, if you re-enable this setting the popups DO NOT COME BACK.

    Try unchecking this setting, hitting Apply, then reenabling the setting. So far it looks to me like it solves the problem with no loss of functionality. I can't explain it, but it appears to be working....
    • CommentAuthorjbones
    • CommentTimeNov 14th 2012
     permalink
    I hope this gets fixed faster than Eset's problem their having with an update in Sept. from Microsoft that is messing with their program too which hasn't even been resolved yet. Haven't seen such problems like this before from hotfixes it's getting very frustrating.
    • CommentAuthornoeldude
    • CommentTimeNov 14th 2012
     permalink
    This seems to be fixed for me as of just a few minutes ago. You guys change something?
    • CommentAuthortomazyk
    • CommentTimeNov 14th 2012
     permalink
    There's a lot of users of OpenDNS that don't use an account and can't change those settings. I hope that OpenDNS will take care of this problem for those users also.
  5.  permalink
    "There's a lot of users of OpenDNS that don't use an account and can't change those settings."

    You are bound to have problems eventually if not using an account and keeping your IP updated.
    • CommentAuthortomazyk
    • CommentTimeNov 14th 2012
     permalink
    Until now I never had any problems with using OpenDNS with no IP associated to account. Neither did any of my friends.
    Is there any official information that OpenDNS servers should be used with accounts only?
    • CommentAuthorrotblitz
    • CommentTimeNov 14th 2012
     permalink
    No official information, but human logic if one understands how this works.
    • CommentAuthortomazyk
    • CommentTimeNov 14th 2012
     permalink
    By logic basic Domain name resolving should work without accounts.
    • CommentAuthorjohncag
    • CommentTimeNov 14th 2012
     permalink
    is this issue resolved now? has something changed in OpenDNS ?
    • CommentAuthorcraig_k
    • CommentTimeNov 14th 2012
     permalink
    Uninstalling update KB2750841 worked for me to fix it.
    • CommentAuthorcharlieo
    • CommentTimeNov 14th 2012
     permalink
    Just re-enabled NXDOMAIN redirect. Looks like it IS fixed. Waited 30 minutes, cleared DNS cache, and rebooted. No pop-ups. EnableActiveProbing was reset to "1" last night....

    Anyone else seeing this as fixed?

    Charlie
  6.  permalink
    I just reinstalled the windows update on this win7 64 computer and not getting the pop ups. I didn't mess with the nxdomain redirection, so everything else is the same.
    • CommentAuthorraydixon
    • CommentTimeNov 14th 2012
     permalink
    I noticed this last night and didn't have time to sort out which workaround I wanted to use. I logged on this morning (about 45 minutes ago) and was getting the pop-ups. I had to step away for a bit and put my laptop in sleep mode. I just logged back in and I'm not getting the pop-ups. I never changed any settings so it looks to me like OpenDNS made a change that fixed the problem.

    It would be nice to hear from someone at OpenDNS to confirm this assumption and explain what their fix is.
    • CommentAuthortomazyk
    • CommentTimeNov 14th 2012
     permalink
    I installed updates on system in Vitualbox and both of my computers and I don't get the popup any more.

This discussion has been inactive for longer than 30 days, and is thus closed.