Your IP:

Our Forums Have Moved!

Visit our new forums at http://community.opendns.com/forums/ to post on topics and read the latest content. These forums are now read-only archives.

K-12 Forums

Talk with other K-12 network administrators in your state.

Or see all states.

Categories

Vanilla 1.1.4 is a product of Lussumo. More Information: Documentation, Community Support.

This discussion has been inactive for longer than 30 days, and is thus closed.
    • CommentAuthorargus
    • CommentTimeApr 29th 2007 edited
     permalink
    When I compare OpenDNS results with other DNS servers I can see some differences. It looks like OpenDNS is redirecting requests for www.google.com to its own servers.

    Could you explain what is going on here?

    ---
    1st query using OpenDNS:

    ; <<>> DiG 9.3.2 <<>> @208.67.222.222 www.google.com

    ;; QUESTION SECTION:
    ;www.google.com. IN A

    ;; ANSWER SECTION:
    www.google.com. 30 IN CNAME google.navigation.opendns.com.
    google.navigation.opendns.com. 30 IN A 208.69.34.230
    google.navigation.opendns.com. 30 IN A 208.69.34.231

    ---
    2nd query using my ISPs DNS server:

    ;; QUESTION SECTION:
    ;www.google.com. IN A

    ;; ANSWER SECTION:
    www.google.com. 566561 IN CNAME www.l.google.com.
    www.l.google.com. 58 IN A 209.85.129.147
    www.l.google.com. 58 IN A 209.85.129.99
    www.l.google.com. 58 IN A 209.85.129.104

    ;; AUTHORITY SECTION:
    l.google.com. 48162 IN NS e.l.google.com.
    l.google.com. 48162 IN NS f.l.google.com.
    l.google.com. 48162 IN NS g.l.google.com.
    l.google.com. 48162 IN NS a.l.google.com.
    l.google.com. 48162 IN NS b.l.google.com.
    l.google.com. 48162 IN NS c.l.google.com.
    l.google.com. 48162 IN NS d.l.google.com.

    ;; ADDITIONAL SECTION:
    a.l.google.com. 48295 IN A 209.85.139.9
    b.l.google.com. 48295 IN A 64.233.179.9
    c.l.google.com. 48295 IN A 64.233.161.9
    d.l.google.com. 48295 IN A 66.249.93.9
    e.l.google.com. 48295 IN A 209.85.137.9
    f.l.google.com. 48295 IN A 72.14.235.9
    g.l.google.com. 48295 IN A 64.233.167.9
    • CommentAuthorjole
    • CommentTimeApr 29th 2007
     permalink
    There is a MAJOR problem with OpenDNS, for some reason it is doing some weird caching with http://google.com/accounts, wreaking havoc on pretty much any API access. Here's a capture

    HTTP/1.0 401 Unauthorized

    WWW-Authenticate: GoogleLogin realm="https://www.google.com/accounts"

    Cache-Control: private

    Content-Length: 167

    Date: Sun, 29 Apr 2007 20:25:16 GMT

    Content-Type: text/html

    Server: GFE/1.3

    X-Cache: MISS from bld6.nyc.opendns.com

    Via: 1.0 bld6.nyc.opendns.com:80 (squid/2.6.STABLE12)

    Connection: close



    <HTML>
    <HEAD>
    <TITLE>Authorization required</TITLE>
    </HEAD>
    <BODY BGCOLOR="#FFFFFF" TEXT="#000000">
    <H1>Authorization required</H1>
    <H2>Error 401</H2>
    </BODY>
    </HTML>
    •  
      CommentAuthordavidu
    • CommentTimeApr 30th 2007
     permalink
    Administrator
    Jole,

    We're going to fix this ASAP. This happens if you have shortcuts enabled in your account. A temporary fix is to turn off shortcuts. A permanent fix will be put in place tomorrow morning.
    Thankful People: OpenDNS User, nessdan
    •  
      CommentAuthordavidu
    • CommentTimeApr 30th 2007
     permalink
    Administrator
    Jole,

    Can you confirm that things are working now?
  1.  permalink
    I still don't see an answer to why OpenDNS is redirecting google traffic to its own address. This makes google work slower for me with OpenDNS than without.
    ~~~~~~~~~~~~~~~~~
    Also I have an oddity on news.bbc.co.uk.
    OpenDns resolves to 212.58.240.132, with a ping time of 85ms.
    My regular ISP resolves to 212.58.226.20, with a ping time of 10ms.

    I am UK based. Perhaps even your London server is giving IP addresses more suitable for some other geography?
    ~~~~~~~~~~~~~~~
    These were my first two 'random' tests of OpenDNS, it isn't too promising a start.
    Thankful People: rweir, vlz, Red Prince, littlemousling
    •  
      CommentAuthordavidu
    • CommentTimeMay 1st 2007
     permalink
    Administrator
    Toddsecond,

    Looking into both your issues now. They are totally unrelated, but being investigated. :-)
    • CommentAuthorrweir
    • CommentTimeMay 12th 2007
     permalink
    Hi,

    this still seems to be happening:

    $ dig www.google.com a
    <<elided>>
    ;; QUESTION SECTION:
    ;www.google.com. IN A

    ;; ANSWER SECTION:
    www.google.com. 30 IN CNAME google.navigation.opendns.com.
    google.navigation.opendns.com. 30 IN A 208.67.219.230
    google.navigation.opendns.com. 30 IN A 208.67.219.231

    I do *not* have shortcuts enabled (nor typo correction, nor phishing protection). It appears to be proxying requests to the real www.l.google.com, which is somewhat worrying, as Google sets a cookie (which is would also be received by the OpenDNS proxy). Note that this happens whether someone is logged in or not. Is there a way to disable this? What's it for, anyway?

    -rob
    • CommentAuthorjoosts
    • CommentTimeMay 13th 2007
     permalink
    Ok, this is what I get when i ping www.google.nl:

    _____________________________________________________________

    PING google.navigation.opendns.com (208.69.34.230) 56(84) bytes of data.
    64 bytes from google.navigation.opendns.com (208.69.34.230): icmp_seq=1 ttl=51 time=21.9 ms
    64 bytes from google.navigation.opendns.com (208.69.34.230): icmp_seq=2 ttl=51 time=17.6 ms
    64 bytes from google.navigation.opendns.com (208.69.34.230): icmp_seq=3 ttl=51 time=18.4 ms
    64 bytes from google.navigation.opendns.com (208.69.34.230): icmp_seq=4 ttl=51 time=19.3 ms

    --- google.navigation.opendns.com ping statistics ---
    4 packets transmitted, 4 received, 0% packet loss, time 3021ms
    rtt min/avg/max/mdev = 17.653/19.369/21.970/1.630 ms

    _____________________________________________________________

    I am really curious about the reason for this.
    • CommentAuthormrofone
    • CommentTimeMay 15th 2007
     permalink
    Here's another site that does not work when shortcuts are enabled:
    www.LewRockwell.com
    Just thought this info might help you track down the problem.
    • CommentAuthorahoier
    • CommentTimeMay 15th 2007
     permalink
    that site works for me...and Im logged in, and using every feature available.
  2.  permalink
    Thanks for pointing that out. Could be a serious privacy issue. Will have to keep my eye on this and wait before I recommend this service.
    • CommentAuthordlmatthews
    • CommentTimeMay 19th 2007 edited
     permalink
    I just tried OpenDNS out today, and I too find that Google is resolving to OpenDNS severs - why isn't the DNS request returning Google's actual IP address? I am concerned that this is happening, and what other web-sites is this done for? - is there a particular reason for it?

    I also have the problem with OpenDNS deciding to resolve www.bbc.co.uk to "212.58.240.121" with a very slow ping of at least 80ms, whereas my ISP's DNS resolves www.bbc.co.uk to "212.58.224.86" and has a 7ms ping.
    • CommentAuthorsimonzerafa
    • CommentTimeMay 20th 2007 edited
     permalink
    Hi,

    This still appears to be happening, as least yesterday it was.

    Google UK (www.google.co.uk) is being redirected to a IP in the OpenDNS 208.67 range, the correct IP address should be 216.239.59.103.

    I have yet to see a good explination for this nor a fix being pushed to the service.

    Can someone from OpenDNS please explain exactly why this is happening, it is by design and if so why this was done?

    Kind Regards

    Simon

    P.S. After disabling shortcuts on my account the IP now resolves to 64.233.183.147 which is still not really correct.
    • CommentAuthordlmatthews
    • CommentTimeMay 20th 2007
     permalink
    Yes, its still happening and is making both Google & the BBC site slower than normal. Hopefully someone can provide some info tomorrow.
    • CommentAuthorfreddy
    • CommentTimeMay 23rd 2007
     permalink
    The reason:
    http://blog.opendns.com/2007/05/22/google-turns-the-page/

    I really don't like this new "feature" !!!
    How many OpenDNS users are Dell customers???
    At least I would like to see a feature to disable this "feature", it should be disabled by default.
    Why don't you simply figure out how to remove this software?
    I even would prefer this dell results, simply because the yahoo results are useless (And all this ads will be filtered by our local proxy).
    I'll stop using OpenDNS if this doesn't change soon!
    Thankful People: jdpower, mrelvey, anubis1975
    • CommentAuthorjoosts
    • CommentTimeMay 23rd 2007
     permalink
    At least it is now clear why this is being done.

    @Freddy: This is no new "feature", this is repairs what Google has broken.

    It would be nicer if you could turn it off or on, though.
    Thankful People: mrelvey
    • CommentAuthorroderikk
    • CommentTimeMay 23rd 2007
     permalink
    Would this also explain the issues I raised in this page:
    http://forums.opendns.com/comments.php?DiscussionID=248&page=1#Item_8

    Since google is being redirected the "I am feeling lucky" poll might not be put through? Just guessing here though...
    • CommentAuthorpencoyd
    • CommentTimeMay 23rd 2007
     permalink
    @freddy, we're not in the client software business, installing or removing. And it's not just Dell that has this. Sony, Gateway, and emachines are all doing the same thing with Google.

    See for yourself:
    http://www.google.com/hws/dell/afe?hl=en&s=http://microsoft.xom
    http://www.google.com/hws/gateway/afe?hl=en&s=http://microsoft.xom
    http://www.google.com/hws/sony/afe?hl=en&s=http://microsoft.xom
    http://www.google.com/hws/emachines/afe?hl=en&s=http://microsoft.xom
    • CommentAuthorahoier
    • CommentTimeMay 24th 2007
     permalink
    Google has money, these computer manufacturers want it.

    And well, it's easier to do business with Google, than to do business with other "software" companies, and jam the new computers full of "trial-ware"....you know? :) lol. I still remember my first computer, a Packard Bell, came packaged with sooo much crap...now? They just shove some Google products (mine only had Google Desktop...), a custom google search page, and a URL redirector service...lol.
    • CommentAuthorfreddy
    • CommentTimeMay 24th 2007 edited
     permalink
    Still I can't see which dell/gateway/sony/emachines/... customer is not able to remove the redirect software but is able to setup OpenDNS.

    But ok. Is it only www.google.com is filtered by OpenDNS or are there any other domains?
    • CommentAuthorahoier
    • CommentTimeMay 24th 2007
     permalink
    freddy has a good point ;) Sure, it took me a bit of prodding to figure out what was causing those errors, but eventually I found Windows Vista's "Add Remove Programs" equivalent, and was able to remove the URL Redirector program, and it was all gold. We gotta understand though, as ISPs and college networks jump on this bandwagon, less-tech people will be using it too.

    The problem here, is I don't think OpenDNS can offer this sort of support...since these corporations are making money off of this "software"...? Though I could be mistaken :P
    • CommentAuthordlmatthews
    • CommentTimeMay 24th 2007 edited
     permalink
    Well, I might have been happier with this if:-
    a) OpenDNS were up front with why Google pages were resolving to one of OpenDNS's servers (they were asked over 3 weeks ago it would seem).
    b) there was an option for OpenDNS account holders to disable this interception, so DNS is resolved correctly
    c) I hadn't seen OpenDNS's attempt to make the Dell pre-installed software an item of Spyware; 1. its installed by the computer manufacturer, 2. the page actually tells the user exactly how to install it. Er, am I missing something, what is the problem. Computer manufacturers have been in deals with software suppliers & service providers for years, such as anti-virus trials, browsers, messengers, ISP desktop links, etc.

    OpenDNS's article probably pushed it over the edge for me; could have been understanding if OpenDNS simply implemented this workaround and advised as such, rather than a full-blown attempt to make Google look bad.


    If the ability to switch off this "feature" for account based users comes along, then I will happily consider using OpenDNS; as it is, not too likely that I'll hook any other networks up to this.

    Its all Google's country domains that are intercepted in this manner, eg google.com, .co.uk, .es, etc etc.


    ...and is there any indication why the London server resolves the BBC sites to IP's which are 80ms response as opposed to the usual 7ms?
    Thankful People: jdpower, srday, jherman1
    • CommentAuthorptaylor874
    • CommentTimeMay 25th 2007
     permalink
    I just started using OpenDNS tonight. I imagine that they aren't saying much about why they are doing this because they may still be figuring out the best way to react.

    It would be nice if they offered an option to disable this additional handling they are doing, but that hasn't started yet.

    As I see it, we are all benefiting from a free ad-driven service. Dell has decided to pre-install software on their machines to make ad money off of their customers. This just seems plain wrong, if you ask me. The customer has already purchased the machine, why look to profit further.

    By doing what Dell has done, they could potentially take away a significant portion of the ad revenue of this service. If OpenDNS were to lose enough revenue, they could go out of business. To me, it seems as if OpenDNS is attempting to modify things in as unobtrusive a way as possible to keep the revenue stream going that Dell is trying to take for themselves.
    • CommentAuthorpdxmph
    • CommentTimeMay 25th 2007
     permalink
    <i>If the ability to switch off this "feature" for account based users comes along, then I will happily consider using OpenDNS; as it is, not too likely that I'll hook any other networks up to this.</i>

    This arrangement just broke Google for me in the middle of the work day, or so the Squid pages coming from a proxy server somewhere in OpenDNS' domain indicated. Since I had no idea how long it would take to fix things, I did myself the favor of dropping OpenDNS from my network. I had no horse at all in the Dell/Google/OpenDNS race, but I do have an interest in being able to use tools I depend on to do my job without wondering why they're broken.

    I'll second the quoted comment above: A toggle that allows me to bypass this sort of behavior will be adequate incentive to reconsider using OpenDNS again.
    • CommentAuthorahoier
    • CommentTimeMay 27th 2007
     permalink
    My guess, is by resolving the google domains to opendns names, they can possibly prevent the certain URL Redirector software from hijacking the Google page? Since it'll be grabbing it from google.navigation.opendns.com instead of www.google.com?

    But, google.com still pings as normal (to Google).
    • CommentAuthormattd
    • CommentTimeMay 27th 2007
     permalink
    Please turn this off.

    It is an absolute joke that you are doing this to stop Dell+Google "hijacking", when OpenDNS is doing THE EXACT SAME THING with your bullshit OpenDNS search portal that hijacks my "I'm feeling Lucky" searches.
    Thankful People: jdpower, srday, littlemousling
    • CommentAuthorjshier
    • CommentTimeMay 28th 2007
     permalink
    OpenDNS doesn't do that. "I'm Feeling Lucky" works fine for me on all of my machines using OpenDNS.

    Still, I think an option to turn it off would be great. Especially since I'm using a Mac and can't be affected by this.
    • CommentAuthorreport99
    • CommentTimeMay 28th 2007
     permalink
    People we are speaking about third party system extension which is installed by default to your purchased machines and running.

    Please, Apple fans are already enough, stop being blind fan of huge fortune 500 companies just because they claimed they are not evil.

    Ask Dell, Sony about how much money did they get for breaking your privacy. I can even understand spyware, it "does" something for free, it steals personal data/habit additionally as price. I can't understand paying for hardware and still defending "man in the middle" software preinstalled to that machine without your absolute agreement.
    :shocked:
    • CommentAuthorjshier
    • CommentTimeJun 28th 2007
     permalink
    Bit of an overreaction, don't you think? Every DNS provider can redirect, snoop, or intercept your requests, so I don't see what you're gaining here. And OpenDNS is actually open and accountable, unlike the anonymous DNS servers of your ISP.
  3.  permalink
    Scott:

    I'll admit that while that was my *initial* reaction ... I think OpenDNS does a very good job of explaining why -- and how -- they're doing it.

    See http://blog.opendns.com/2007/05/22/google-turns-the-page/

    It's long but I recommend that you read it. (it took me a couple of re-reads for it to soak-in)

    I agree w/ jshier that OpenDNS' openness ... and I'll add the extra funtionality they provide ... still outweigh the "potential" risks -- at least for me.

    Besides, If you're looking for sleezy scumbag behavior, you generally don't have to look much further than your own ISP. They know and see EVERYTHING, many are now starting DNS re-directs to their own sponsored advertisers*, and most have few qualms about selling the info they have on you -- as well as your clickstream data -- to every bidder they can find.

    * For example, check out this "fine and helpful" example of the DNS redirect Cox provides in selected markets when mis-typing microsoft.xom
    http://finder.cox.net/main?ClientLocation=us&ParticipantID=default&FailureMode=4&linkid=tsCB8H8AAAEAAH3tSzkAAABF&SearchQuery=microsoft.xom

    I agree that it's incumbent on users to keep OpenDNS honest ... but IMO they're still "delivering."

    Call it "Trust ... w/ verification" :wink:
  4.  permalink
    I'd also like an option to turn off intercepting Google (and any other sites you may do this for in the future). I don't need it, and even if OpenDNS is doing it for a good reason, it makes me uncomfortable.
    Thankful People: jdpower, srday, jherman1, littlemousling
  5.  permalink
    I don't disagree.

    We could work-around by adding an entry for Google to our Hosts file ...

    ... but this shouldn't be that hard an "option" for OpenDNS to implement given their pace of rolling-out other features.
  6.  permalink
    $ host www.google.com
    www.google.com is an alias for www.l.google.com.

    Is this a fluke, or did somebody disable this on my account? If it's the latter, that is totally awesome. Thanks. :bigsmile:

    CacheCheck is reporting the same thing, but then again, this IP is associated with my account. So, what's up?

    Update a few minutes later:

    I just thought to try an nslookup from my web host, and it still returns google.navigation.opendns.com. So I guess this is just for my account. Well, thanks a lot! :smile:

    I think it would be a good thing to have in the Advanced settings or something though.

    Also, it's weird for CacheCheck's results to vary depending on who's using it.
    • CommentAuthorfreddy
    • CommentTimeJul 1st 2007
     permalink
    If you've a UNIX based router.

    This will remove the google redirection:
    iptables -t nat -A PREROUTING -d 208.69.34.230 -j DNAT --to 66.102.9.104
    iptables -t nat -A PREROUTING -d 208.69.34.231 -j DNAT --to 66.102.9.104
    You should replace 66.102.9.104 with an IP for www.google.* for your own location.
    66.102.9.104 is fine for Europe.

    You might also want to add these to make sure that there are no connection to the OpenDNS redirection servers:
    iptables -t nat -A PREROUTING -d 208.69.34.230 -j DROP
    iptables -t nat -A PREROUTING -d 208.69.34.231 -j DROP
    iptables -t nat -A PREROUTING -d 208.69.34.232 -j DROP
    iptables -t nat -A PREROUTING -d 208.69.34.233 -j DROP
    iptables -t nat -A PREROUTING -d 208.69.34.234 -j DROP
    iptables -t nat -A PREROUTING -d 208.69.34.235 -j DROP
    iptables -A OUTPUT -d 208.69.34.230 -j DROP
    iptables -A OUTPUT -d 208.69.34.231 -j DROP
    iptables -A OUTPUT -d 208.69.34.232 -j DROP
    iptables -A OUTPUT -d 208.69.34.233 -j DROP
    iptables -A OUTPUT -d 208.69.34.234 -j DROP
    iptables -A OUTPUT -d 208.69.34.235 -j DROP
    Seems like OpenDNS is preparing (maybe it's already working) the redirection of MSN and Yahoo.
  7.  permalink
    Ohhhh. I just read an older thread where davidu explained that turning off shortcuts is what disables it. Well, okay. I don't ever plan on using shortcuts, so it's not a problem.

    (I don't get why adult site blocking relies on shortcuts, though.)

    Update a few minutes later:

    About a checkbox to turn intercepting Google off without turning off shortcuts, a month ago, davidu said that the two features were too tied together in their codebase to do it, but that that might change in the future:

    http://forums.opendns.com/comments.php?DiscussionID=278&page=1#Item_9
    • CommentAuthorctolla
    • CommentTimeJul 20th 2007
     permalink
    There should definitely be an option to disable this redirecting of Google queries. I'll give them some time, but if it's not in place soon I'll cease using OpenDNS on privacy concerns.
    Thankful People: jdpower, srday
    • CommentAuthorbconway
    • CommentTimeJul 31st 2007
     permalink
    It appears that turning off shortcuts to turn off this behavior no longer works? I had shortcuts turned off under the old dashboard and got the _real_ Google IP(s). Now under this new dashboard, I have no shortcuts entered and have chosen "Do not apply any of my shortcuts", but I still get:

    $ ping www.google.com
    PING google.navigation.opendns.com (208.67.217.230) 56(84) bytes of data.
    64 bytes from 208.67.217.230: icmp_seq=1 ttl=53 time=15.7 ms
    64 bytes from 208.67.217.230: icmp_seq=2 ttl=53 time=15.5 ms
    ...

    Is there another way to turn off shortcuts that I'm missing?
    • CommentAuthormrbudman
    • CommentTimeAug 4th 2007
     permalink
    Well I turned off use of shortcuts last night, an still doing it this morning. This is not good, I really would like to continue using opendns. But stuff like this is pure nonsense.

    To get around it until they see the error of their ways, I have just put in a forward zone to the google nameservers directly.. which is a lot easier than iptable rules as suggested above ;)

    This still forwards uncached queries to opendns, except for anything related to google.com

    zone "google.com" {
    type forward;
    forwarders {
    216.239.32.10;
    216.239.34.10;
    216.239.36.10;
    216.239.38.10;
    };
    };
    Thankful People: amishmm, blinks, Red Prince
    • CommentAuthorsia
    • CommentTimeAug 8th 2007
     permalink
    Same here, i've shortcuts off and Google redirection still happens.

    I would never notice it, but Google homepage was occasionally hanging for me and local users, so i've started to investigate why.

    Prior to introduction of such bold feature intercepting crucial network resource i would recommend to ensure that:

    - it can be turned off

    - probably it is off by default unless user asks for it

    - it is done completely transparently with the level of redundancy and reliability at least approaching Google's.

    As it is now it does more harm than good; unless i can turn it off i'm likely to revert to ISP nameservers for this office.

    --igor
    Thankful People: srday, jherman1
    • CommentAuthoramishmm
    • CommentTimeAug 15th 2007 edited
     permalink
    UPDATE:
    I just found a better and simpler directive:
    zone "google.com" {
    type forward;
    };

    This is sufficient no need for any other directive. This will make named STOP using OpenDNS forwarder for anything.google.com and serve the request itself.

    OLD POST FOLLOWS:
    To add to johnpoz post you also need to add this:

    zone "l.google.com" {
    type forward;
    forwarders {
    209.85.139.9;
    64.233.179.9;
    64.233.161.9;
    66.249.93.9;
    209.85.137.9;
    72.14.235.9;
    64.233.167.9;
    };
    forward only;
    };

    forward only is reqed if you have specified "forward first;" in global section.
  8.  permalink
    I agree, this is ridiculous. A DNS service should not be hijacking DNS for known names, period. I will NOT be recommending OpenDNS because of this. I discovered it on my own and found this thread in the process.

    Reason for hijacking google.com to google.navigation.opendns.com: profit. See below.

    Why was I asked to research this? My users complained that every mistyped URL took them to a OpenDNS page. All my users use Firefox and a feature of Firefox is to redirect unresolved DNS to a Google lucky search. Why is OpenDNS hijacking this feature for their own profit? I know they must generate a revenue, but this is unethical. What other valid DNS is being redirected without my knowledge? Why didn't they tell me?

    And why did OpenDNS target Firefox? Safari doesn't seem affected - I didn't test anything else either.

    Here's some proof:
    "ebay" in Firefox redirects to http://www.google.com/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q=ebay
    (via 'network.http.redirection-limit=0')

    $ wget http://www.google.com/search?ie=UTF-8\&oe=UTF-8\&sourceid=navclient\&gfns=1\&q=ebay
    --23:45:48-- http://www.google.com/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q=ebay
    Resolving www.google.com... 208.67.217.230, 208.67.217.231
    Connecting to www.google.com|208.67.217.230|:80... connected.
    HTTP request sent, awaiting response... 302 Moved Temporarily
    Location: http://guide.opendns.com/?url=ebay&client=ff20 [following]
    --23:45:48-- http://guide.opendns.com/?url=ebay&client=ff20
    Resolving guide.opendns.com... 208.69.32.131
    Connecting to guide.opendns.com|208.69.32.131|:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: unspecified [text/html

    Reverse resolve outside OpenDNS:208.67.217.230 resolved to google.navigation.opendns.com
    Oh, that make sense.
  9.  permalink
    Other ISP's are following suit. My local ISP - Zoomtown by Cincinnati Bell also uses the redirect tactic described above. Despicable.

    Temporary solution: switch to my ISP's business DNS servers that do not have this flaky policy. You may wish to do the same, with a possible increase in speed.
    http://zoomtown.net/
    • CommentAuthoriamnoone
    • CommentTimeSep 21st 2007
     permalink
  10.  permalink
    What’s the point of this one sided moderated blog which won’t publish any criticism of OpenDNS?

    http://blog.opendns.com/2007/05/22/google-turns-the-page/


    It’s bull - that’s what it is,. Not everyone is happy for the blanket application of this so called solution of applying an interception of google queries to OpenDNS servers - yet, only the comments of those are published who are easily led enough to believe the content of this blog entry with regards to Google and Dell - where (if the problem actually exists) will only affect a minority, but a solution to which, is dished out to the majority.

    I would doubt seriously, that google and Dell would dent their sales by causing resentment to their customers.

    I wrote a scathing criticism in response, which obviously wasn't published. In the meanwhile I suggest changing your hosts file or to stop using this service altogether.
    • CommentAuthoratomota
    • CommentTimeDec 18th 2007
     permalink
    I've been using OpenDNS for less than a day and found the Google issue, a BBC issue, and now this thread. I won't be using OpenDNS any more, thanks.

    I'm running dnsmasq (on a router running OpenWrt). Although it's easy enough to put this into
    /etc/dnsmasq.conf:

    local=/google.com/216.239.32.10/216.239.34.10/216.239.36.10/216.239.38.10

    I will be pointing my nameservers somewhere else to get plain old DNS service.

    Furthermore, http isn't the only protocol on the net, and it's misleading to get errors like this one when using other protocols and typo'd server names get translated to OpenDNS servers:

    Connecting to upload.blah.com (208.67.219.130) at port 21...
    connect(): Connection refused

    OpenDNS, if you're serious about the user experience, let the Google redirection, and similar features, be opt-in. FWIW I've got two Dells running Windows XP and I don't recall ever having seen the Google toolbar on either of them.
    • CommentAuthorsunnz
    • CommentTimeFeb 13th 2008
     permalink
    I just came across this thread during a search... can anyone fill in what happened since?

    I just compared a dig result from OpenDNS and ISP's DNS, they seem to both resolve to the same A record...
    • CommentAuthoraard
    • CommentTimeMar 3rd 2008 edited
     permalink
    this causes all of my google searches to be redirected to http://sorry.google.com/sorry/ - this pretty much makes opendns useless to me.
    • CommentAuthorpinchies
    • CommentTimeMar 9th 2008
     permalink
    I am annoyed at the www.l.google.com redirect. Not using OpenDNS, and my google addresses are always www.google.com. Now, as soon as I do a search, I get redirected to www.l.google.com.

    What gives? Can I change this?
    Thankful People: m_wright
  11.  permalink
    @pinchies

    It seems l.google.com is the real deal:
    http://blogoscoped.com/forum/125859.html

    Some thought it was opendns, but robtex proves it's not

    http://www.robtex.com/dns/www.google.com.html

    However, it is odd that you're forced into l.google.com when it's invisible for most. Even if you don't have an opendns account, and therefore couldn't have had shortcuts/filtering on.
    • CommentAuthorjms
    • CommentTimeMar 10th 2008
     permalink
    openDNS is still hijacking google.com and google.de to google.navigation.opendns.com.
    This is like phishin.
    I will quit using openDNS.
    Thankful People: watabou90

This discussion has been inactive for longer than 30 days, and is thus closed.