Your IP:

Our Forums Have Moved!

Visit our new forums at http://community.opendns.com/forums/ to post on topics and read the latest content. These forums are now read-only archives.

K-12 Forums

Talk with other K-12 network administrators in your state.

Or see all states.

Categories

Vanilla 1.1.4 is a product of Lussumo. More Information: Documentation, Community Support.

This discussion has been inactive for longer than 30 days, and is thus closed.
    • CommentAuthorbengarland
    • CommentTimeMar 14th 2009 edited
     permalink
    I searched and found another user experienced the same thing, but their issue was never resolved (the only reply was a pointer to other threads that did not exactly address the issue).

    When I use OpenDNS for my DNS servers, YouTube loads videos very slowly (it is actually impossible to watch anything). The second I switch back to my ISP DNS, YouTube videos load fast.

    I KNOW OpenDNS is ONLY a DNS server and should not affect my download speeds -- BUT IT DOES, at least on YouTube. It does not matter if I use a Mac (10.5.6) or a PC (XP SP3) I get the same results.

    What is going on?

    If you don't believe me, I made screen videos of both so you can see how huge the difference is. This is not a fluke, I can repeat the results over and over by changing the DNS servers in my router from using OpenDNS to using my ISP's.


    Here's what happens with OpenDNS:

    [removed screen movie from server but basically the "loading" spinner in youtube would sit there spinning, then the video would play for 1-2 seconds, then go back to the loading spinner for 20 seconds, then play a couple seconds, etc]


    Here's what happens with my ISP DNS:

    [removed screen movie from server but with my ISP DNS the movie loads fine and plays without a problem]



    EDIT: Adding youtube.com to my whitelist does nothing.

    Clearly, something is going on...

    Ben
    Thankful People: rws265
    • CommentAuthorrotblitz
    • CommentTimeMar 14th 2009 edited
     permalink
    What area are you located?
    What OpenDNS servers are you using? http://www.opendns.com/support/article/208

    Locate the URL of a video, especially the domain name.
    nslookup <video-FQDN> 208.67.222.222
    nslookup <video-FQDN> <your-ISP's-DNS>
    Do they return different results (IP addresses) for the video domain name?
    • CommentAuthorbengarland
    • CommentTimeMar 14th 2009 edited
     permalink
    I am located in Raleigh, NC, USA on Time Warner Cable 6 Mbit/sec.

    dig +noall +answer which.opendns.com txt @208.67.222.222
    which.opendns.com. 0 IN TXT "7.ash"


    It appears the video is hosted from:

    http://s.ytimg.com/yt/swf/watch-vfl82913.swf

    EDIT: Upon further investigation, this is only for the container SWF. The FLV video file is being served from v19.cache.googlevideo.com


    Here's what I got using the dig command. I don't know how to specify DNS servers, so I just changed it on the router side. I have no idea what this means, other than that the DNS is returning completely different results depending on if I am using OpenDNS or my ISP DNS.


    For the router set to OPEN DNS this is what I got:

    dig s.ytimg.com

    ; <<>> DiG 9.4.2-P2 <<>> s.ytimg.com
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 58401
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;s.ytimg.com. IN A

    ;; ANSWER SECTION:
    s.ytimg.com. 509 IN CNAME static.cache.l.google.com.
    static.cache.l.google.com. 206 IN A 74.125.100.21

    ;; Query time: 43 msec
    ;; SERVER: 192.168.0.1#53(192.168.0.1)
    ;; WHEN: Sat Mar 14 18:28:03 2009
    ;; MSG SIZE rcvd: 81



    --------------------------------------------
    --------------------------------------------

    For router set to MY ISP DNS this is what I got:

    dig s.ytimg.com

    ; <<>> DiG 9.4.2-P2 <<>> s.ytimg.com
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 49336
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 7, ADDITIONAL: 6

    ;; QUESTION SECTION:
    ;s.ytimg.com. IN A

    ;; ANSWER SECTION:
    s.ytimg.com. 23 IN CNAME static.cache.l.google.com.
    static.cache.l.google.com. 198 IN A 74.125.7.27

    ;; AUTHORITY SECTION:
    l.google.com. 29436 IN NS c.l.google.com.
    l.google.com. 29436 IN NS b.l.google.com.
    l.google.com. 29436 IN NS e.l.google.com.
    l.google.com. 29436 IN NS f.l.google.com.
    l.google.com. 29436 IN NS a.l.google.com.
    l.google.com. 29436 IN NS g.l.google.com.
    l.google.com. 29436 IN NS d.l.google.com.

    ;; ADDITIONAL SECTION:
    e.l.google.com. 82831 IN A 209.85.137.9
    g.l.google.com. 84076 IN A 74.125.95.9
    d.l.google.com. 84067 IN A 74.125.77.9
    a.l.google.com. 84076 IN A 209.85.139.9
    c.l.google.com. 70142 IN A 64.233.161.9
    b.l.google.com. 83181 IN A 74.125.45.9

    ;; Query time: 21 msec
    ;; SERVER: 192.168.0.1#53(192.168.0.1)
    ;; WHEN: Sat Mar 14 18:27:05 2009
    ;; MSG SIZE rcvd: 289
    • CommentAuthorrotblitz
    • CommentTimeMar 14th 2009 edited
     permalink
    <which.opendns.com. 0 IN TXT "7.ash">
    So you're using the Ashburn WDC servers, which should be fine.

    "I don't know how to specify DNS servers,"
    It's just the second argument, for both, nslookup, as I had shown, and dig, but for dig you must preceed a @ sign.

    "the DNS is returning completely different results"
    Not completely, but only slightly: 74.125.100.21 and 74.125.7.27 are not really different, but still somewhat different. Btw, for me it returns 74.125.8.208.

    Now the next exercises:
    tracert 74.125.100.21
    tracert 74.125.7.27
    (Maybe on the Mac it's traceroute.)
    • CommentAuthorbengarland
    • CommentTimeMar 14th 2009 edited
     permalink
    Thanks for the help so far.


    [this is the one that OpenDNS points to]

    traceroute 74.125.100.21
    traceroute to 74.125.100.21 (74.125.100.21), 64 hops max, 40 byte packets
    1 192.168.0.1 (192.168.0.1) 2.768 ms 1.112 ms 1.175 ms
    2 cpe-075-189-128-001.nc.res.rr.com (75.189.128.1) 13.097 ms 7.938 ms 12.510 ms
    3 gig0-1-5.rlghnca-rtr2.nc.rr.com (66.26.33.81) 10.162 ms 11.548 ms 8.985 ms
    4 ge-2-3-0.chrlncpop-rtr1.southeast.rr.com (24.93.64.176) 22.085 ms 22.471 ms 22.489 ms
    5 ae-3-0.cr0.atl20.tbone.rr.com (66.109.6.82) 35.518 ms 22.799 ms 25.945 ms
    6 ae-0-0.pr0.atl20.tbone.rr.com (66.109.6.171) 29.488 ms 30.333 ms 38.212 ms
    7 66.109.9.90 (66.109.9.90) 29.044 ms 27.546 ms 54.164 ms
    8 64.233.174.2 (64.233.174.2) 24.886 ms 23.279 ms 25.760 ms
    9 209.85.251.8 (209.85.251.8) 51.935 ms 40.827 ms 37.530 ms
    10 209.85.250.55 (209.85.250.55) 105.377 ms 107.591 ms 122.734 ms
    11 209.85.130.84 (209.85.130.84) 108.346 ms 105.185 ms 107.764 ms
    12 209.85.248.80 (209.85.248.80) 112.751 ms 113.655 ms 113.004 ms
    13 209.85.254.251 (209.85.254.251) 114.037 ms 209.85.254.100 (209.85.254.100) 113.523 ms 209.85.254.251 (209.85.254.251) 118.838 ms
    14 * * *
    15 74.125.100.21 (74.125.100.21) 112.635 ms * 113.428 ms


    [this is the one that my ISP DNS points to]

    traceroute 74.125.7.27
    traceroute to 74.125.7.27 (74.125.7.27), 64 hops max, 40 byte packets
    1 192.168.0.1 (192.168.0.1) 1.661 ms 2.045 ms 1.184 ms
    2 cpe-075-189-128-001.nc.res.rr.com (75.189.128.1) 8.121 ms 8.988 ms 21.759 ms
    3 gig0-1-5.rlghnca-rtr2.nc.rr.com (66.26.33.81) 10.164 ms 11.101 ms 9.797 ms
    4 ge-2-3-0.chrlncpop-rtr1.southeast.rr.com (24.93.64.176) 22.231 ms 21.615 ms 22.106 ms
    5 ae-3-0.cr0.atl20.tbone.rr.com (66.109.6.82) 24.456 ms 24.225 ms 22.395 ms
    6 ae-0-0.pr0.atl20.tbone.rr.com (66.109.6.171) 48.913 ms 27.805 ms 28.756 ms
    7 66.109.9.90 (66.109.9.90) 29.411 ms 30.993 ms 27.878 ms
    8 72.14.239.100 (72.14.239.100) 26.007 ms 24.691 ms 64.233.174.2 (64.233.174.2) 26.025 ms
    9 72.14.233.55 (72.14.233.55) 23.908 ms 72.14.233.57 (72.14.233.57) 25.044 ms 25.444 ms
    10 * * *
    11 74.125.7.27 (74.125.7.27) 31.163 ms 30.413 ms 28.030 ms
    • CommentAuthorrotblitz
    • CommentTimeMar 14th 2009 edited
     permalink
    Yes, you are right, you are really having a problem. The IP address 74.125.100.21 returned by OpenDNS is a not so good one for you to reach s.ytimg.com. The route is much different, and the latency is three and a half times worse, especially as you have only a 6Mbit connection.

    The only thing you can do is to raise a support ticket at http://www.opendns.com/support/contact/
    But think about that it's weekend, so you may have to wait until at least Monday for a response. If you wanted a very quick temporary workaround, you had to append the domains in question to your hosts files, e.g.
    74.125.7.27 s.ytimg.com static.cache.l.google.com
    i.e. always the IP address returned by your ISP, the domain name and aliases.
    Sorry for not having better news.
    Thankful People: maintenance
    • CommentAuthorbengarland
    • CommentTimeMar 14th 2009
     permalink
    Thanks rotblitz, at least I'm not crazy :-)
    • CommentAuthorRed Prince
    • CommentTimeMar 14th 2009
     permalink
    >>gave me "** server can't find s.tyimg.com: NXDOMAIN"<<

    It gave you the correct answer. Even though there is a tyimg.com, there is no s.tyimg.com. Now, had you asked for s.ytimg.com instead, you would have gotten a different answer. :bigsmile:
    • CommentAuthorbengarland
    • CommentTimeMar 15th 2009
     permalink
    Ah, redprince... thanks, I didn't notice my own typo!

    rotblitz: I changed it in my /etc/hosts file and the problem is still there (I even flushed my DNS cache)... guess I'll wait until Monday and file a trouble ticket.
    • CommentAuthorrotblitz
    • CommentTimeMar 15th 2009
     permalink
    On a Mac it is slightly different. I think you have to manipulate also resolv.conf and dhcp.conf (or so). Sorry, I'm not a Mac expert, just heard about it. On Windows the hosts file trick would do.
    • CommentAuthorbengarland
    • CommentTimeMar 15th 2009 edited
     permalink
    I did some more digging and figured out that the .swf file is appears to be calling a .flv file that is hosted at:

    v19.cache.googlevideo.com

    When using my ISP DNS, it wants to pull the video from 74.125.165.88 -- and the video downloads in about 90 seconds. In fact, the first 1/4th of the video comes in at a whopping 800 KB(ytes)/sec, then it seems it is trottled at the source end down to about 100 KB/sec for the rest (I'm assuming this is how they do it for youtube to keep their bandwidth in check).

    When using OpenDNS, it wants to pull the video from 74.125.100.100 -- and the video download crawls along and the estimated completion time is 20+ minutes.

    (I am downloading just the FLV file separate from the youtube page using my browser's download manager)


    If I manually put this IP in the URL for the .flv (no matter what I have my DNS set to), I get the same results. That is, I can put the "good/fast" IP in the URL and get a fast download even when using OpenDNS servers.

    Apparently something is happening where OpenDNS is returning this "bad/slow" IP when looking up v19.cache.l.googlevideo.com


    Here are the traceroutes...

    Fast IP resolved from my ISP DNS:

    traceroute to 74.125.165.88 (74.125.165.88), 64 hops max, 40 byte packets
    1 192.168.0.1 (192.168.0.1) 2.025 ms 1.157 ms 1.383 ms
    2 cpe-075-189-128-001.nc.res.rr.com (75.189.128.1) 9.329 ms 9.279 ms 10.638 ms
    3 gig0-1-5.rlghnca-rtr2.nc.rr.com (66.26.33.81) 9.397 ms 9.982 ms 12.173 ms
    4 ge-2-3-0.chrlncpop-rtr1.southeast.rr.com (24.93.64.176) 23.403 ms 24.978 ms 22.305 ms
    5 ae-3-0.cr0.atl20.tbone.rr.com (66.109.6.82) 26.996 ms 29.258 ms 54.368 ms
    6 ae-0-0.pr0.atl20.tbone.rr.com (66.109.6.171) 27.743 ms 24.607 ms 24.976 ms
    7 66.109.9.90 (66.109.9.90) 26.744 ms 29.009 ms 38.127 ms
    8 64.233.174.2 (64.233.174.2) 27.172 ms 30.931 ms 72.14.239.100 (72.14.239.100) 26.979 ms
    9 * * 66.249.95.148 (66.249.95.148) 70.338 ms
    10 216.239.48.109 (216.239.48.109) 29.822 ms 32.502 ms 32.364 ms
    11 * * *
    12 74.125.165.88 (74.125.165.88) 31.900 ms 30.864 ms 33.417 ms



    Slow IP resolved from OpenDNS:

    traceroute to 74.125.100.100 (74.125.100.100), 64 hops max, 40 byte packets
    1 192.168.0.1 (192.168.0.1) 1.777 ms 1.036 ms 1.161 ms
    2 cpe-075-189-128-001.nc.res.rr.com (75.189.128.1) 10.193 ms 9.689 ms 10.177 ms
    3 gig0-1-5.rlghnca-rtr2.nc.rr.com (66.26.33.81) 9.242 ms 10.388 ms 12.510 ms
    4 ge-5-3-0.chrlncpop-rtr1.southeast.rr.com (24.93.64.2) 21.008 ms 14.513 ms 15.084 ms
    5 ae-3-0.cr0.atl20.tbone.rr.com (66.109.6.82) 48.953 ms 19.008 ms 19.073 ms
    6 ae-0-0.pr0.atl20.tbone.rr.com (66.109.6.171) 25.172 ms 24.124 ms 190.027 ms
    7 66.109.9.90 (66.109.9.90) 23.506 ms 26.486 ms 24.219 ms
    8 64.233.174.2 (64.233.174.2) 20.675 ms 20.111 ms 24.662 ms
    9 209.85.251.8 (209.85.251.8) 32.976 ms 32.607 ms 35.372 ms
    10 209.85.250.55 (209.85.250.55) 133.307 ms 100.730 ms 103.978 ms
    11 66.249.95.130 (66.249.95.130) 110.397 ms 209.85.130.84 (209.85.130.84) 112.793 ms 66.249.95.130 (66.249.95.130) 101.179 ms
    12 209.85.248.80 (209.85.248.80) 107.125 ms 109.711 ms 209.85.254.101 (209.85.254.101) 130.531 ms
    13 209.85.254.251 (209.85.254.251) 108.559 ms 108.057 ms 109.527 ms
    14 * * *
    15 74.125.100.100 (74.125.100.100) 110.890 ms 109.025 ms 107.336 ms
    • CommentAuthorRed Prince
    • CommentTimeMar 15th 2009
     permalink
    Strange, I'm getting NXDOMAIN for v19.cache.l.googlevideo.com.
    • CommentAuthorbengarland
    • CommentTimeMar 15th 2009
     permalink
    Sorry, I got confused (it's been a long night)... the correct is v19.cache.googlevideo.com .. I got mixe up because one of the dig answers also contained v19.cache.l.google.com (the CNAME for the previous address)... I guess I got them transposed in my head.
    • CommentAuthorbengarland
    • CommentTimeMar 15th 2009
     permalink
    rotblitz: I got the /etc/hosts to work, apparently Apple changed the command in 10.5 to flush the cache.

    It is now

    dscacheutil -flushcache


    Unfortunately this works only for a single video server, e.g.

    74.125.165.88 v19.cache.googlevideo.com


    If I go to a different youtube video, it might be coming from server v7, for example and OpenDNS reverts to resolving a slow IP.

    :(
    • CommentAuthorroyal
    • CommentTimeMar 15th 2009 edited
     permalink
    I am having the same issue as you have. The only way to fix it is to use IP DNS servers. :sad:
    • CommentAuthorrotblitz
    • CommentTimeMar 15th 2009
     permalink
    @bengarland

    "Unfortunately this works only for a single video server..."
    Yes, you might have to add a lot of domains to your hosts file, unfortunately. :sad:
    Let's hope that OpenDNS come up with a solution next week. :confused:

    "dscacheutil" - Isn't it dnscacheutil? :cool:
    • CommentAuthorbengarland
    • CommentTimeMar 15th 2009
     permalink
    rotblitz -- Actually it is dscacheutil... at first I also thought "dns" too (and was wondering why it didn't work when I typed "dnscacheutil") ... but the "ds" stands for Directory Service.
    • CommentAuthorroyal
    • CommentTimeMar 15th 2009 edited
     permalink
    Looks like it has been fixed! YouTube finally loads video fast. :bigsmile:
    • CommentAuthorrotblitz
    • CommentTimeMar 15th 2009
     permalink
    So, "royal" is an alias for "bengarland", right? Confusing...
    Glad to hear that the problem is solved. Apparently it was a routing error somewhere, not necessarily related to OpenDNS, which has been fixed by a third party in between.
    • CommentAuthorbengarland
    • CommentTimeMar 15th 2009 edited
     permalink
    EDIT: I checked again a few hours later and it is NOT FIXED.

    (I am not related to user "royal"... we are just having the same problem)

    I sent a message to support.
    Thankful People: wubba, borlaugseed
    • CommentAuthorstephenv2
    • CommentTimeMar 16th 2009
     permalink
    I'm still having the same problem - TWC in Greensboro
  1.  permalink
    Problems out of Dayton, OH on TWC/RR as well.

    On my computer, I edited the DNS to one that is well known but not filtered like OpenDNS.
    YouTube files opened and loaded without issue.
    I think someone either directly or indirectly has put a blacklist on YouTube through OpenDNS thereby causing problems for everyone.

    I do hope it gets corrected soon.
    • CommentAuthorbengarland
    • CommentTimeMar 16th 2009
     permalink
    Just an update, I checked again and the problem has returned. Cannot load video again...
  2.  permalink
    I just installed OpenDNS for the first time a few hours ago with high hopes that it would provide a satisfactory, free internet filtering solution. However, I have experienced the same problem described here (Youtube video will not play). I can't believe this has not been addressed before now. I am using a home computer rather than managing a server. I hope this gets resolved in a few days or I'll have to try something else.
  3.  permalink
    I have also had this same problem with YouTube after I started using OpenDNS. The YouTube page opens quickly, but the videos themselves often load only the first few seconds before stopping.
    • CommentAuthora1242b
    • CommentTimeMar 16th 2009
     permalink
    I have this problem as well. This page came up in a Google search while I was trying to figure out how to resolve it.
    I've switched back to ISP DNS servers for now, and hopefully this will be fixed soon.
    • CommentAuthorrotblitz
    • CommentTimeMar 16th 2009
     permalink
    And you all have opened a ticket at http://www.opendns.com/support/contact/ hopefully?
  4.  permalink
    Yes, I opened a ticket last evening. It's 10:45AM CST on Monday and OpenDNS now appears to play Youtube videos fine. They must have adjusted something. Thanks!
    • CommentAuthorstephenv2
    • CommentTimeMar 16th 2009
     permalink
    it's back again. opening a ticket.
  5.  permalink
    Hey folks - things you may want to check if you're having Youtube issues:

    1) Are you blocking ad servers/sites?

    2) Have you removed all filters to see if the behavior goes away (thus indicating it's due to some sort of filter - this can then be narrowed down and resolved after).

    3) Is your IP current and being updated properly?

    We are looking into this as a systemic problem, but oftentimes this behavior occurs from other circumstances. Please feel free to open up support tickets as needed, and if possible, include the output of the following diagnostic checks in the tickets:

    http://www.opendns.com/support/article/208 *AND* http://www.opendns.com/support/article/224 (when using the OpenDNS servers).
    Thankful People: maintenance, alkora, a1242b, rws265
    • CommentAuthorembro
    • CommentTimeMar 17th 2009
     permalink
    Had the same problem.
    Problem was at resolving or requesting any information from ytimg.com (a domain used by youtube.com).

    Switched back to other DNS while this is being fixed.
    • CommentAuthorbengarland
    • CommentTimeMar 17th 2009
     permalink
    mmirenzi:

    1) Not blocking anything.

    2) No filters in use.

    3) My IP is current. It is also the IP that OpenDNS "sees" (dig myip.opendns.com).


    I think it is a systemic problem. I am using 7.ash if that makes a difference. I already opened a support ticket (and received a response) yet the issue persists.
    • CommentAuthorrws265
    • CommentTimeMar 17th 2009
     permalink
    I'm experiencing the same issue as the rest here.
    • CommentAuthora1242b
    • CommentTimeMar 17th 2009
     permalink
    Youtube is working for me now. Using 5.ash and following article 224, it does resolve in my ip address. BTW, the final period in the command in article 224 is important as it makes a difference in the results.

    I have adware & phishing blocked.

    I also have these items on my whitelist, but I did not have them there when I first experienced the problem:
    cache.googlevideo.com
    googlevideo.com
    s1.youtube.com
    s2.youtube.com
    s.ytimg.com
    v18.googlevideo.com
    v19.googlevideo.com
    v20.googlevideo.com
    youtube.com
    I added the above items because after I disabled open dns and went to youtube, those were the connections I was able to see that Youtube appeared to open.

    If it stops working again for me, I'll open a ticket.
  6.  permalink
    My previous trouble with Youtube videos not playing seems to be OK today.
    • CommentAuthorRed Prince
    • CommentTimeMar 17th 2009
     permalink
    @a1242b: That is redundant. Whitelisting a domain automatically whitelists all of its subdomains, so you can reduce that list to these three:

    youtube.com
    googlevideo.com
    ytimg.com
    • CommentAuthordnstelegt
    • CommentTimeMar 17th 2009 edited
     permalink
    I was experiencing the same issue here .GT However, adding to my whitelist:

    youtube.com
    googlevideo.com
    ytimg.com

    worked for me. As for speed, my connection is slow, so I can not tell the difference.

    Thanks redprince
    • CommentAuthorRed Prince
    • CommentTimeMar 17th 2009
     permalink
    You're welcome.
    • CommentAuthormiked
    • CommentTimeMar 17th 2009
     permalink
    Many sites like YouTube are hosted on large load-balanced systems, with multiple IP addresses. They will often decide, at the DNS level, to split traffic up among systems by handing back different IP addresses.

    It looks like YouTube was instructing OpenDNS to send users to a group of servers that were experiencing network issues. Switching back to your ISPs DNS servers "fixed" the problem because YouTube was telling them to send you to another location not having issues (note that there are probably cases you don't notice where the opposite is true).

    Ultimately this is an issue between one of YouTube's locations and your ISP. We have no visibility into the quality of the connection between your ISP and any given site, so we can only direct you to the IP address the site owner tells us to send you to.


    Also, whitelisting a given domain at OpenDNS will have no effect on the quality of service your ISP provides.
    Thankful People: Red Prince
    • CommentAuthorstephenv2
    • CommentTimeMar 17th 2009
     permalink
    this issue remains unresolved - i opened a ticket yesterday but now other video sites seem affected. I'm turning off OpenDNS system wide until as fix in place
    • CommentAuthorncwebb
    • CommentTimeMar 17th 2009
     permalink
    Definitely, Definitely slow!! I changed back to my ISP DNS and work smooth as silk. On open DNS wouldn't even load pages for YouTube neverless playback video. Hope they fix this soon!!
    • CommentAuthorstephenv2
    • CommentTimeMar 17th 2009
     permalink
    Confirmed again on all machines - with ISP DNS, youtube and links to youtube work perfectly
    • CommentAuthorrotblitz
    • CommentTimeMar 17th 2009
     permalink
    miked wrote above: "Ultimately this is an issue between one of YouTube's locations and your ISP."
    So, what ISP's do you guys (or gals) have? All the same???
    Btw, I do not have any issues with any YouTube videos...
    • CommentAuthorncwebb
    • CommentTimeMar 18th 2009
     permalink
    I have timewarner. There was an instant difference after switching back to timewarner's DNS. It only affected YouTube.
    • CommentAuthora1242b
    • CommentTimeMar 18th 2009 edited
     permalink
    Its back. Youtube is affected. Videos on mtv are also not working properly, but that may be unrelated to DNS issues. Users report hulu works fine. . OpenDNS currently disabled so users can get their video fix. I've it enabled for my machine only, and will open a ticket shortly.


    redprince
    Thanks, I didn't know if I needed to whitelist them separately or not, as blacklisting doesn't seem work that way and I have to blacklist each separate subdomain I don't want.

    I have Brighthouse/ Roadrunner. I'm located in central Florida.

    I've opened a ticket, but it seems slow, but still watchable this morning.
    • CommentAuthormiked
    • CommentTimeMar 18th 2009
     permalink
    So you are both using Time Warner/Road Runner?

    You should contact them and ask why you are having connectivity issues to 74.125.100.100
    • CommentAuthorstephenv2
    • CommentTimeMar 18th 2009
     permalink
    i'm roadrunner in GSO, NC. But I've switched off OpenDNS and everything is fine, but DNS is slower
    • CommentAuthorncwebb
    • CommentTimeMar 18th 2009
     permalink
    I have no problem when using timewarner DNS, just Open DNS. It is as if timewarner does something to OpenDNS. My connection is like stephenv2. OpenDNS=slow youtube timewarner=fast youtube.
    • CommentAuthormiked
    • CommentTimeMar 18th 2009 edited
     permalink
    Pretend for a second no DNS lookups were taking place. If you attempted to download a video BY IP ADDRESS from 74.125.100.100, you would experience the same speed issues.

    This is a routing issue between your ISP and that network.


    Now, bringing DNS back into the mix: the reason the issue goes away when switching back to your ISPs DNS is they are handing back a different IP address than OpenDNS. We cannot control the address that the site (YouTube in this case) tells us to direct you to. Neither can your ISP. As I mentioned in my previous post, there are probably cases where the inverse is true... your ISPs DNS is handing back an IP address you will experience high latency to, but OpenDNS responds with an IP that is perfectly fine from your network.

    Once again, DNS does not impact the throughput or latency of your connection.
    • CommentAuthorbengarland
    • CommentTimeMar 19th 2009
     permalink
    Thanks for the additional info, miked.

    I am also using TWC/Roadrunner...

    I'll give them a call next week when I get back in town, although I don't know how to reach one of their network engineers -- I'm guessing the idiots in Tier 1 tech support will have no clue.

This discussion has been inactive for longer than 30 days, and is thus closed.