Your IP:

Our Forums Have Moved!

Visit our new forums at http://community.opendns.com/forums/ to post on topics and read the latest content. These forums are now read-only archives.

K-12 Forums

Talk with other K-12 network administrators in your state.

Or see all states.

Categories

Vanilla 1.1.4 is a product of Lussumo. More Information: Documentation, Community Support.

This discussion has been inactive for longer than 30 days, and is thus closed.
    • CommentAuthorgabe_u
    • CommentTimeMar 23rd 2011
     permalink
    I live in Italy and i have internet service from Telecom Italia (Alice) and they give you their own routers, they suck because you cannot configure it, so i connected my AirPort Express to it so i can setup the OpenDNS for all the devices in the house.
    I set up the Internet (connection) sharing as bridge.
    But there is one small problem is not working (i set it up exactly like here https://store.opendns.com/setup/device/apple-airport). The DNS servers are not recognize and if i remove the DNS servers from my computer then i get this error http://www.opendns.com/support/article/307.

    I really do not understand why if i set the DNS on my computer everything is working but if i set them on the AirPort Express is not working.
  1.  permalink
    The core problem here is that many Italian ISPs do not assign customers each their own public IP address, so you cannot use OpenDNS filtering nor update your IP to OpenDNS at all. Other here seem to have used Telecom Italia with OpenDNS successfully in the past, but the IP mismatch indicates that the address from which your DNS requests originate is different from the address that you use for other activity like web browsing. You should check with the ISP on this.

    As to Airport routers, they generally assign DNS IPs to client machines, and cannot be configured manually for DNS on the WAN side. So, configuring the Airport should have the same result as configuring the computers. If your Airport is capable of being configured on the WAN side, you still need to make sure that the Airport is properly bridged for this use and that the computers are looking to the Airport and not right through it to the other router.

    But never mind the router right now, as you need to resolve the http://www.opendns.com/support/article/307 issue, which is best done by checking with your ISP first. (Do I have my own, unshared public IP address? Is my IP address the same for DNS requests as it is for HTTP traffic?)
    Thankful People: rotblitz, zelus, OpenDNS User
    • CommentAuthorrotblitz
    • CommentTimeMar 23rd 2011 edited
     permalink
    "Is my IP address the same for DNS requests as it is for HTTP traffic?"

    @gabe_u
    This is what you can find out yourself.
    Your "DNS" IP address:
    Windows: nslookup myip.opendns.com. 208.67.222.222
    Mac OS: dig +noall +answer myip.opendns.com. @208.67.222.222
    Then compare with your "web" IP address: http://myip.dnsomatic.com/
    Thankful People: gabe_u
    • CommentAuthorgabe_u
    • CommentTimeApr 16th 2011
     permalink
    Sorry for the late response i forgot about this.
    @rotblitz i tested and i receive the same ip address
    but the program from opendns is shows that i have 212.48.8.140.

    @maintenance i have one single question.

    if i set the ip dns in my Macbook at System Preferences->Network->Advanced->Dns the settings for opendns is working,
    but when i set it on my Airpot Express exactly like here https://store.opendns.com/setup/device/apple-airport why is not working?

    and even if i set the airport express to work as a normal router, i mean is not set as bridge is still not working.
    • CommentAuthorrotblitz
    • CommentTimeApr 16th 2011
     permalink
    "but the program from opendns is shows that i have 212.48.8.140."

    If this is different from what you get via DNS lookup and DNS-O-Matic, then you're most likely behind a proxy. What does http://welcome.opendns.com/ say?

    "and even if i set the airport express to work as a normal router, i mean is not set as bridge is still not working."

    Yes, DNS and DHCP settings do only take place when you operate it in router mode, not in bridge mode. Why do you think it isn't working?
    Thankful People: maintenance

This discussion has been inactive for longer than 30 days, and is thus closed.