Your IP:

Our Forums Have Moved!

Visit our new forums at https://community.opendns.com/forums/ to post on topics and read the latest content. These forums are now read-only archives.

K-12 Forums

Talk with other K-12 network administrators in your state.

Or see all states.

Categories

Vanilla 1.1.4 is a product of Lussumo. More Information: Documentation, Community Support.

This discussion has been inactive for longer than 30 days, and is thus closed.
    • CommentAuthorftrt4tg
    • CommentTimeFeb 27th 2012
     permalink
    The telnet command described for this router is the following
    dns server route add dns=208.67.222.222 metric=5 intf=Internet
    but it doesn't work.

    It should be as below
    dns server route add dns=208.67.222.222 metric=0 intf=ipInternet
    • CommentAuthornpr
    • CommentTimeFeb 27th 2012
     permalink
    "It should be as below
    dns server route add dns=208.67.222.222 metric=0 intf=ipInternet "

    No, the interface name (intf) will vary with different ISP custom firmware.
    You can find the correct interface name for your firmware with the command --- dns server route list
    The intf name show by this command is the one to use.

    You may find the instructions here are more complete.
    http://npr.me.uk/telnet.html
    • CommentAuthorrotblitz
    • CommentTimeFeb 27th 2012
     permalink
    @npr, brilliant job!
    And at Google rank 1 with that subject matter.
  1.  permalink
    Following these suggestions I have:


    {steve}=>:dns server route list

    DNS Server Entries:
    DNS Server Source Label Metric Intf State Domain
    S 206.67.220.220 0 Static_IP UP *
    S 206.67.222.222 0 Static_IP UP *


    but what do I do to get a host in my network to pick up one of these DNS servers because at the moment I have no stats in my OpenDNS console ?
  2.  permalink
    Maybe I should add that all of the hosts in my network are picking up the router's private IP as the DNS server...(192.168.1.254) or does that then cause the router to send proxy DNS to the Open DNS server ?
  3.  permalink
    I noticed a couple more things:

    1. When I look at the Mac OpenDNS updater it says that the network is not using OpenDNS
    2. The OpenDNS servers are not pinging from my home network...but maybe they are configured to not respond to ICMP ?
    • CommentAuthornpr
    • CommentTimeFeb 29th 2012
     permalink
    "Following these suggestions I have:
    {steve}=>:dns server route list"

    Which instructions?
    If it's the ones on opendns help page then recheck "dns server route list" after 24 hrs. The commands there may allow the ISP's DNS to creep back in to the router via DHCP, often with a lower metric so it take a higher priority over odns.

    "The OpenDNS servers are not pinging from my home network."
    ping 208.67.222.222 should work.
    If it doesn't work it's being blocked by a firewall (software on the pc or router firewall -- unlikely) or the ISP is blocking / redirecting outside DNS resolvers.

    Are you saying after setting odns in the router that your devices are not using it?
    Try this website to check http://welcome.opendns.com/
    • CommentAuthorrotblitz
    • CommentTimeFeb 29th 2012 edited
     permalink
    @popeye591910

    To see if your DNS lookups are being redirected by your ISP:
    nslookup -type=txt which.opendns.com. 208.67.222.222
    - or -
    dig +noall +answer which.opendns.com txt @208.67.222.222
    - or -
    host -t txt which.opendns.com 208.67.222.222

This discussion has been inactive for longer than 30 days, and is thus closed.