Your IP:

Our Forums Have Moved!

Visit our new forums at https://community.opendns.com/forums/ to post on topics and read the latest content. These forums are now read-only archives.

K-12 Forums

Talk with other K-12 network administrators in your state.

Or see all states.

Categories

Vanilla 1.1.4 is a product of Lussumo. More Information: Documentation, Community Support.

This discussion has been inactive for longer than 30 days, and is thus closed.
    • CommentAuthorsteelkbu
    • CommentTimeMay 24th 2012
     permalink
    I was happy at first because I thought I figured everything out with my Verizon FIOS router (Actiontec MI424WR) and OpenDNS. I even had an open thread - http://forums.opendns.com/comments.php?DiscussionID=13733

    Following the advice of that thread, I tried to hook up a Linksys router with dd-wrt flashed. No luck. Apparently because I am using a MOCA based network, setting up a router behind the gateway is not really an option. Any suggestions or help? I have already tried this thread http://forums.opendns.com/comments.php?DiscussionID=7724 and others like it. But when I change the DNS IP's in my router it disrupts my cable TV. Verizon uses its own DNS to verify that I am using its equipment.
  1.  permalink
    "But when I change the DNS IP's in my router it disrupts my cable TV."

    You would leave that bit of your network connected to the original gateway, connecting only computing devices to the Linksys, and the Linksys to the gateway. This is the entire point of the exercise.
    • CommentAuthorsteelkbu
    • CommentTimeMay 24th 2012
     permalink
    Would this require me to create a bridge between the Actiontec router and the Linksys?
  2.  permalink
    Does the rest of you network work now? If so, then why would you need to change anything configuration-wise? You simply cannot have IPTV or VOIP using DNS other than what is given by the provider, so you would connect those devices to the network gateway which has the ISP DNS.
    • CommentAuthorrotblitz
    • CommentTimeMay 24th 2012 edited
     permalink
    "Would this require me to create a bridge between the Actiontec router and the Linksys?"

    You connect both with an Ethernet cable. If this doesn't work, you'll want to try with a cross-over Ethernet cable instead. You may have to configure the routers to work on different IP address subnets.

    You connect IPTV and VoIP to the Actiontec device, and the rest to the Linksys device where the OpenDNS addresses are configured.
    • CommentAuthorsteelkbu
    • CommentTimeMay 25th 2012
     permalink
    Wouldn't this suggestion create a double NAT?
  3.  permalink
    That depends. You'd have to follow router instructions for both devices to ensure you get the behavior you want.
    • CommentAuthorsteelkbu
    • CommentTimeMay 26th 2012
     permalink
    Any suggestions on how to avoid a double NAT?
    • CommentAuthorrotblitz
    • CommentTimeMay 26th 2012
     permalink
    You must run the outer device in bridged / passthrough mode. But if you do this to the device, your IPTV and/or VoIP may suffer again. Why would you like to avoid double NAT?
    • CommentAuthoretharp
    • CommentTimeMay 27th 2012
     permalink
    Check out : http://www.dd-wrt.com/wiki/index.php/Linking_Routers
    It was helpful for me when I added a DD-WRT router with my Verizon FIOS router so I could have 802.11n network as well as the FIOS 802.11g. There is even a section in the wiki about adding OpenDNS
    Thankful People: rotblitz
    • CommentAuthorsteelkbu
    • CommentTimeMay 27th 2012
     permalink
    So far I have my Actiontec router working with my Linksys router. I disabled the wireless access on my Actiontec and now I am connected to my Linksys router. I followed these directions to get me where I am today - http://www.dslreports.com/faq/12506

    My only issue is that my Linksys router that has "tomato" installed, cannot update opendns nor dns-o-matic through the built in DNS updater. I feel like the Actiontec router is blocking the DNS update somehow. Any suggestions?
  4.  permalink
    There should be an error message either displayed or in a log. Find out what that error is, and we can start to troubleshoot.
    • CommentAuthorrotblitz
    • CommentTimeMay 27th 2012
     permalink
    • CommentAuthorsteelkbu
    • CommentTimeMay 28th 2012 edited
     permalink
    Here is the error I get - "Dec 31 19:17:51 unknown user.info ddns-update[916]: Time not yet set."

    I set the time up correctly and it will not update.

    Update - I don't believe my Actiontec router is assigning an IP to my Linksys router.
  5.  permalink
    "I don't believe my Actiontec router is assigning an IP to my Linksys router. "

    Then nothing behind that router could communicate with the Actiontec and the internet. Look at the WAN IP of the Linksys. That would be it's IP address with respect to the Actiontec.

    "I set the time up correctly and it will not update."

    So, is the error the same, then? Unknown user would be the key, then. You must be sending the update to OpenDNS, which is in the drop-down list. If you are not, the only other service OpenDNS accepts updates from is DNS-O-Matic, and you would have to have an account configured there. Sending updates through a service that does not know you, or that OpenDNS does not recognize, will fail. "Unknown user" would imply that the service does not know you.

    So, if you are sending to OpenDNS, then your credentials (username, password, and network label (for which I see no field in the first link, usually "hostname" or "network")) must be exactly as they are at your Dashboard, and they are *case sensitive*.

    Further, you cannot use any HTTP reserved or unsafe characters.
    http://www.blooberry.com/indexdot/html/topics/urlencoding.htm
    http://www.ietf.org/rfc/rfc1738.txt
    • CommentAuthorrotblitz
    • CommentTimeMay 28th 2012
     permalink
    On the other hand:
    "Dec 31 19:17:51 unknown user.info ddns-update[916]: Time not yet set."

    We don't have Dec 31. Unless this is an old message from then, you still may have a problem with the date/time on the router.

    As this problem is not really OpenDNS specific, you better use the support facilities available for Tomato.
    http://www.polarcloud.com/tomatofaq#but_what_about
    • CommentAuthorsteelkbu
    • CommentTimeJun 1st 2012
     permalink
    I've gone round on a few forums and I am not sure that a VZ FIOS MOCA connection that shares TV and internet can work with OpenDNS. The issue is that when you set up a router to use the OpenDNS server addresses, the VZ cable TV will not work. That is because VZ set top boxes utilize the VZ DNS server addresses. Without the VZ DNS server addresses the Set top boxes will NOT work. If I had just an internet package from VZ, this would not be an issue. But I have TV and internet packaged together.
  6.  permalink
    Which is the entire point of putting another router behind the gateway to which to connect only computers and on which to set the OpenDNS addresses.

    We keep moving on, or back around the circle, without addressing points raised...
    • CommentAuthorsteelkbu
    • CommentTimeJun 5th 2012
     permalink
    I made my previous comment about the inability to use OpenDNS and FIOS MOCA connection based on this -

    "Requests to bridge the MI424WR are often based on a misunderstanding
    that it is both a router and a modem, it is not. (Actiontec does produce DSL
    Gateways that support Transparent-Bridging. When Transparent-Bridging is
    enabled, it bypasses or disables the gateway’s router function and allows the
    Gateway to function simply as a DSL modem.) Many customers do not
    realize that with FiOS, the ONT (typically outside the home) is the device
    that most closely resembles a modems function. That it handles changing
    the FiOS signal from Fiber to either Ethernet or Coax, and that the Router is
    just a Router, and if it were bridged or bypassed, it would be a device that
    no longer had a purpose. Most Verizon FiOS customers would lose their VoD
    service, if the MI424WR was successfully bridged in this fashion, because the
    Video on Demand service is dependent on the router to work."

    Source: http://support.actiontec.com/doc_files/Can_I_Bridge_the_Actiontec_MI424WR_FiOS_Router.pdf
    • CommentAuthorrotblitz
    • CommentTimeJun 5th 2012
     permalink
    You don't need to bridge your FiOS router to connect another router behind. Therefore this article is irrelevant.
    • CommentAuthorsteelkbu
    • CommentTimeJun 20th 2012
     permalink
    Sigh - I keep trying. So, I followed these directions verbatim:

    "Hi... 1st plug a PC directly to the Linksys router alone. Then on this particular PC... open up internet explorer (it's ok if it says "page could not be displayed")... and type on the address bar just the following numbers: 192.168.1.1 (username just leave it blank, password as a default is admin)...

    This process should bring you to a Linksys page... look for something labeled as the "Local IP Address" or the LAN IP Address... if the value is 192.168.1.1.. change this to 192.168.5.1... then save the settings... (page would not be displayed after this.. again that's ok).....

    Then go to the DOS prompt (start---run---type in cmd) .... and type the command ipconfig/release (hit enter)... and then ipconfig/renew (hit enter).....

    Next connect the Actiontech router to the internet/WAN port of the Linksys router. Then do a powercycle. That is turn off all of the devices... router - modem and PC's.. then turn them on in the order of modem--routers-and PC's.......

    After this process, you should now hopefully be online on the PC connected to the Linksys router......."

    When I set up my Linksys (with Tomato firmware) to use OpenDNS in the DDNS settings, I get an "invalid hostname" message. I thought that I would try using DNS-O-Matic instead. However, I get an error message as well. It reads as follows:

    "The IP Address you have supplied to DNS-O-Matic
    differs from the IP Address that you are coming from.
    OpenDNS does not allow you to update to an IP Address
    that you don't actually own."

    Any thoughts?
    • CommentAuthorrotblitz
    • CommentTimeJun 20th 2012
     permalink
    See here http://www.linksysinfo.org/index.php?threads/ddns-with-opendns-and-tomato.30499/

    "The IP Address you have supplied to DNS-O-Matic..."

    What is the IP address?
    • CommentAuthorsteelkbu
    • CommentTimeJun 21st 2012
     permalink
    So I think I got it to work. Instead of using "Use External IP Address 192.168...."" I used "Use External IP Address checker (every 10 minutes)" and I got a successful message. I also chose to use DNS-O-Matic as my service - http://i.imgur.com/sZHBX.jpg

    I think this setup might be double NAT'd, but I guess it will do.
    • CommentAuthormaintenance
    • CommentTimeJun 21st 2012 edited
     permalink
    "instead of using "Use External IP Address 192.168...."""

    Not being an external IP address, but one in private address space, this certainly would not work. (It may be on the WAN side of the second router, but it is by no means your public IP, which is what you need to use to create an OpenDNS Network and update.)

    "I used "Use External IP Address checker"

    You could have looked at the top of the page here, initially, where it says "Your IP:". The checking/update function for the DDNS in the firmware should find the extenal IP to keep it updated.

    Assuming you have an account set up at DNS-O-Matic, you should be fine now.
    • CommentAuthorploosimurax
    • CommentTimeJul 1st 2012 edited
     permalink
    have verizon light-division support send internet over ethernet from the ONT and media over moca. There are several fully functional setups NOT listed at DSLreports fios section. Buy an ethernet appliance that doesn't suck, or build your own pfsense/untangle box. Be sure you have enough backplane bandwidth to accommodate your fios provisioned tier + 15%.

    The STB/DVR require the fourth octet begin at 100; assign incrementally. You are not likely to have more devices than the required range ceiling.

    DHCP is already plenty capable. Learn how to wield it for different devices.
    • CommentAuthorsteelkbu
    • CommentTimeJul 6th 2012
     permalink
    @ploosimurax - I would love to run ethernet from the ONT to the house. But this is not feasible right now.

    So, I have a bit of an issue again. I followed the directions above to hook up my Actiontec and my Linksys (See here:http://forums.opendns.com/comments.php?DiscussionID=14455#Item_21) and all was well. Everything was working. My IP address was being updated and OpenDNS was working. However, just recently, my IP address updated and OpenDNS did not update with it. I also cannot locally connect to my Linksys router anymore (The address is 192.168.1.2). Although, I can connect to the internet through my Linksys. Any thoughts?
    • CommentAuthorrotblitz
    • CommentTimeJul 8th 2012
     permalink
    If you're using Windows, post the output of "ipconfig /all" here.
    • CommentAuthorsteelkbu
    • CommentTimeJul 9th 2012 edited
     permalink
    Sorry - this will be lengthy


    C:\Users\Cr>ipconfig /all

    Windows IP Configuration

    Host Name . . . . . . . . . . . . : PC
    Primary Dns Suffix . . . . . . . :
    Node Type . . . . . . . . . . . . : Hybrid
    IP Routing Enabled. . . . . . . . : No
    WINS Proxy Enabled. . . . . . . . : No

    Wireless LAN adapter Wireless Network Connection 3:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Microsoft Virtual WiFi Miniport Adapter
    Physical Address. . . . . . . . . : 00-00-51-65-00-00
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes

    Wireless LAN adapter Wireless Network Connection 2:

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Broadcom 802.11g Network Adapter #2
    Physical Address. . . . . . . . . : 00-00-41-00-00-CB
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    Link-local IPv6 Address . . . . . : fe00::2003:4f2b:e5cb:4785%17(Preferred)
    IPv4 Address. . . . . . . . . . . : 192.168.5.127(Preferred)
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Lease Obtained. . . . . . . . . . : Sunday, July 08, 2012 8:24:10 PM
    Lease Expires . . . . . . . . . . : Monday, July 09, 2012 8:24:13 PM
    Default Gateway . . . . . . . . . : 192.168.5.1
    DHCP Server . . . . . . . . . . . : 192.168.5.1
    DHCPv6 IAID . . . . . . . . . . . : 503319617
    DHCPv6 Client DUID. . . . . . . . : 00-01-00-00-12-D5-B0-00-00-19-00-BF-9D-00

    DNS Servers . . . . . . . . . . . : 192.168.5.1
    NetBIOS over Tcpip. . . . . . . . : Enabled

    Ethernet adapter VirtualBox Host-Only Network:

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : VirtualBox Host-Only Ethernet Adapter
    Physical Address. . . . . . . . . : 08-00-27-00-04-9F
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes
    Link-local IPv6 Address . . . . . : fe80::40ef:be04:fb9f:eead%28(Preferred)
    IPv4 Address. . . . . . . . . . . : 192.168.56.1(Preferred)
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Default Gateway . . . . . . . . . :
    DHCPv6 IAID . . . . . . . . . . . : 738721001
    DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-12-D5-B1-D2-00-19-66-BF-9D-23

    DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
    fec0:0:0:ffff::2%1
    fec0:0:0:ffff::3%1
    NetBIOS over Tcpip. . . . . . . . : Enabled

    Tunnel adapter isatap.home:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Microsoft ISATAP Adapter
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-00
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Teredo Tunneling Pseudo-Interface:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-00
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter isatap.{0000-D1BF-438A-B918-784BB6091D4D}:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-00
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter isatap.{5D6FE74F-F30C-45A5-9FB5-931362E91DA4}:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Microsoft ISATAP Adapter #3
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-00
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter isatap.{000002-D04B-40B7-B1D1-4744D3E55666}:

    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Microsoft ISATAP Adapter #4
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes
  7.  permalink
    Default Gateway . . . . . . . . . : 192.168.5.1
    DHCP Server . . . . . . . . . . . : 192.168.5.1

    No, this is your router's address.
    Thankful People: steelkbu
    • CommentAuthorsteelkbu
    • CommentTimeJul 9th 2012 edited
     permalink
    Oh wow. I feel kind of like an idiot and a bit inferior....just a bit. Let me try logging into my router when I get home today and I will post my progress. Thank you!

    Also - my router still is not feeding my IP address to DNS-O-Matic. So once I log in to my router tonight, I will see if there are any error messages.
    • CommentAuthorsteelkbu
    • CommentTimeJul 11th 2012
     permalink
    Update

    So I logged onto my router with 192.168.5.1. There was an error message that said something to the effect of - unable to update IP address. So I checked the box that said "Force next update" and it worked. Not sure what that was all about.
    Thankful People: maintenance
  8.  permalink
    I hope everything is in working order for you now.

This discussion has been inactive for longer than 30 days, and is thus closed.