Your IP:

Our Forums Have Moved!

Visit our new forums at to post on topics and read the latest content. These forums are now read-only archives.

K-12 Forums

Talk with other K-12 network administrators in your state.

Or see all states.


Vanilla 1.1.4 is a product of Lussumo. More Information: Documentation, Community Support.

This discussion has been inactive for longer than 30 days, and is thus closed.
    • CommentAuthormatt_d
    • CommentTimeJul 2nd 2012
    I'm just trying to update dnsomatic via my web browser before I conf my router...but the exanple isn't clear.

    Does my hostname replace 'hostname' or 'yourhostname'?
    Similarly does my address replace 'myip' or 'ip adress'?
  1.  permalink
    The bit after the equal signs is where you put your actual credential.
    • CommentAuthormatt_d
    • CommentTimeJul 2nd 2012
    Ok still no go. I'm just trying to test dnsomatic out with my browser before I config my Cisco to do it automatically. I'm using IE9, I try

    But I get a 'nohost' response. I get a request for a user/pass so I know I am contacting the page OK.
  2.  permalink
    I don't see a password in that string, andf your IP address cannot be That is a completely meaningless IP in private address space that millions of people have on the LAN side of their router. Use your public IP address, as this is the only thing which can possibly identify you. It is also the reason for updating in the first place: Dynamic IP addresses. No router dynamically allocates it's own LAN IP to be something different than it ever was to begin with.
    • CommentAuthormatt_d
    • CommentTimeJul 2nd 2012
    The browser prompts for a password with a popup.
    I still get a a 'nohost' reply.

    In reference to the IP, yep I understand private address spaces....but I'm not going to publish my IP on a public forum. Apart from the obvoius logic, I can't see why can't be listed as my IP under my account. dnsomatic doesn't send me any data - it just records my IP? My account identifies me not my ip.

    Eitherway I'm just after a string I can type into my browser, change the address feild, and see that change occur when I login to dnsomatic. Is this possible?
  3.  permalink
    “I can't see why can't be listed as my IP under my account.”

    Because it is not your public IP address. :devil:
  4.  permalink
    Sure, you don't have to post your public IP, but you have to use it in an update. Otherwise, you are updating nothing.

    Yes, you can do this. You have to use the proper IP.
    • CommentAuthormatt_d
    • CommentTimeJul 3rd 2012
    OK. I have changed to a Chrome browser.
    Replacing the XXX with the obvious, I paste the below into my browser:

    I still get a 'nohost' response.
    So I'm missing something - does my account need to be set up in a certain way?. It would be great if someone could actually test the above with their browser.
  5.  permalink
    Do you have any services defined at DNS-O-Matic?

    Are you using HTTP unsafe or reserved characters anywhere in your credentials? Use only what DNS-O-Matic declares is legal in the manner described.
    • CommentAuthormatt_d
    • CommentTimeJul 9th 2012
    Unfortunatley the username of my credentials is my email address and contains an '@' and '.', both http reserved.

    Still getting a 'nohost' response. If I type incorrect credents I get 'badauth' so I'm assuming I'm getting past the authenication.
    • CommentAuthormatt_d
    • CommentTimeJul 9th 2012
    OK I created a network in OpenDNS and it's now working.
    I was expecting dnsomatic to respond to http DDNS requests even if it didn't pass the info on..obviously not.
  6.  permalink
    The HTTP reserved characters are being used as intended, so no conflict.

    No, the update returns whatever the remote service returns as well. Which is also why you got a login box previously - this was the target service asking for credentials.
    • CommentAuthormatt_d
    • CommentTimeJul 9th 2012 edited

    With the service defined in OpenDNS, I did try for intrest sake. From the dnsomatic history:

    The IP Address you have supplied to DNS-O-Matic
    differs from the IP Address that you are coming from.
    OpenDNS does not allow you to update to an IP Address
    that you don't actually own.

    Also...thanks for the help.
    • CommentAuthorrotblitz
    • CommentTimeJul 10th 2012
    Your concerns are irrelevant. The "nohost" response indicates that you didn't have an OpenDNS network with its label referenced as a service defined at DNS-O-Matic.

This discussion has been inactive for longer than 30 days, and is thus closed.