Your IP:

Our Forums Have Moved!

Visit our new forums at https://community.opendns.com/forums/ to post on topics and read the latest content. These forums are now read-only archives.

K-12 Forums

Talk with other K-12 network administrators in your state.

Or see all states.

Categories

Vanilla 1.1.4 is a product of Lussumo. More Information: Documentation, Community Support.

This discussion has been inactive for longer than 30 days, and is thus closed.
    • CommentAuthordscoduc
    • CommentTimeMay 13th 2009
     permalink
    While I can appreciate OpenDNS's feature to always return an IP address even when the resolution isn't resolvable (aka 208.67.219.132) I truly need to disable this feature.

    In other words I want OpenDNS to act like every other DNS server when it is unable to resolve a server name. I don't want to enter each domain to ignore, I just want OpenDNS to return back a standard not found response when there is no address returned.

    Any help would be appreciated.
    • CommentAuthorrotblitz
    • CommentTimeMay 13th 2009
     permalink
    • CommentAuthordscoduc
    • CommentTimeMay 13th 2009 edited
     permalink
    Really? That's the answer from OpenDNS? That OpenDNS won't act like a normal DNS server according to the DNS RFC?

    It makes sense if I am using a web browser that OpenDNS would forward me to a search engine, but for any other dns lookup having this as the default behavior is borderline dangerous.
    Thankful People: thrawn05
    • CommentAuthorrotblitz
    • CommentTimeMay 13th 2009 edited
     permalink
    This is my answer, and I'm an OpenDNS user since Nov 2007.
    Not sure if there is an official OpenDNS answer at all here. They call it "feature".
    https://ssl.scroogle.org/cgi-bin/nbbwssl.cgi?Gw=guide%20site:www.opendns.com

    Edit: Oops, you edited your message in between.
    "but for any other dns lookup having this as the default behavior is borderline dangerous".
    Not that I knew, I use it at home, and my (huge) corporation uses it as well. No problematic side effects have been seen so far.
    • CommentAuthordscoduc
    • CommentTimeMay 13th 2009
     permalink
    Yeah, no worries... I just find it frustratingly annoying that OpenDNS comes back with the guide address instead of host not-found... Perhaps I should look for a DNS service that plans on following the DNS RFC's more closely.

    Thanks for the answer.
    • CommentAuthorRed Prince
    • CommentTimeMay 13th 2009 edited
     permalink
    @cblanken: OpenDNS is not a charity. They provide a service and need to pay for it somehow, while also making reasonable profit. The guide apparently pays for it all.

    If you can find the same level of service for free with no strings attached, by all means switch to it. Just don't expect it to last.

    (No, I don't work for OpenDNS either.)
    Thankful People: miked, cindelicato, dar3z
    • CommentAuthorrotblitz
    • CommentTimeMay 13th 2009
     permalink
    "I should look for a DNS service..."
    Hmm, one has disappeared recently, the second and third have very slow query response times, and the forth and fifth are just too far away, with slow responses therefore either. My ISP's DNS would be the second choice after OpenDNS, they even protect against accessing the Conficker domains, just like OpenDNS.
    • CommentAuthordscoduc
    • CommentTimeMay 14th 2009
     permalink
    Right... did not want to come across crass... Just find it frustrating when I end up with the guide.opendns.com ip address instead of a server not found...

    I'm sure many share in my frustration, judging from the number of other entries in the forums.
    • CommentAuthorlancefu
    • CommentTimeMay 14th 2009
     permalink
    I just go to Advanced Settings and turn off "OpenDNS proxy" and check off "Apply my shortcuts to this network." It took a few minutes to apply to server. Once it's set, I can use Firefox's address bar as search bar again. You guys can try it and see if it works for you.
    Thankful People: lokfear
  1.  permalink
    You can also setup typo/VPN exceptions if the problem is that you cannot resolve within your local network in a Windows environment.
    • CommentAuthormiked
    • CommentTimeMay 14th 2009
     permalink
    cblanken,

    Go to Advanced Settings in your OpenDNS Dashboard and uncheck the boxes under the "Domain Typos" heading.
  2.  permalink
    "I'm sure many share in my frustration, judging from the number of other entries in the forums."

    Perhaps. But given the number of users who are apparently not equally frustrated, perhaps most do not.
    • CommentAuthorrotblitz
    • CommentTimeMay 14th 2009 edited
     permalink
    [revoked]
    • CommentAuthorrunesorli
    • CommentTimeMay 15th 2009
     permalink
    ments

    * big inputEnter you

This discussion has been inactive for longer than 30 days, and is thus closed.