Your IP:

Our Forums Have Moved!

Visit our new forums at https://community.opendns.com/forums/ to post on topics and read the latest content. These forums are now read-only archives.

K-12 Forums

Talk with other K-12 network administrators in your state.

Or see all states.

Categories

Vanilla 1.1.4 is a product of Lussumo. More Information: Documentation, Community Support.

This discussion has been inactive for longer than 30 days, and is thus closed.
  1.  permalink
    Starting a new thread, here is the discussion up to this point...

    =========================================================
    wolfshollywood * 17 hours ago

    Linksys RV042

    You have Linksys listed, but my admin panel is totally different. I have two different sections for DNS Servers.

    1. Under System Setup, for WAN1 and WAN2 (This is where Time Warner had their DNS's)
    2. Under DHCP Setup (previously blank or all 0s)

    I tried changing both of them, but the OpenDNS site is not registering it yet. Do I have to wait?
    ----------------------
    rotblitz * 17 hours ago

    Option 1 is the right one. http://ui.linksys.com/files/RV042/1.2.3/network.htm
    Do not enter the OpenDNS server addresses under DHCP Setup.

    "OpenDNS site is not registering it yet. Do I have to wait?"
    OpenDNS does not register anything, probably a misunderstanding. Flush your browser cache and local resolver cache and then visit http://welcome.opendns.com/ to see if you're using OpenDNS for your DNS lookups.
    Thankful People: wolfshollywood
    ---------------------
    wolfshollywood * 17 minutes ago

    @rotblitz, thanks for the tips.

    Unfortunately, it didn't solve the problem. The weird thing is that it is registering stats under the dashboard. My IP is current. I cleared cache and restarted browser, and double-checked by using a different browser. Still the welcome screen says I'm not using OpenDNS.
    ---------------------
    rotblitz * 9 minutes ago edited

    You better had opened your own thread, as your matter is off-topic here.
    Is it probably this? http://www.opendns.com/support/article/224
    Or do you have a proxy defined in your browser?

    ===============================================================

    I must clarify that I am a total newb to this, so you must talk to me in kindergarten-speak. I don't understand how this all works, but I have some general ideas. I don't know about proxies. Anyhow, I tried running the suggested commands and this is what I got:

    ----------------------------
    nslookup myip.opendns.com.
    Results:
    Server: dns-cac-lb-01.rr.com
    Address: 209.18.47.61

    Non-authoritative answer:
    Name: myip.opendns.com
    Address: 24.28.193.9

    dig myip.opendns.com
    'dig' is not recognized as an internal or external command, operable program or batch file.

    host myip.opendns.com
    'host' is not recognized as an internal or external command, operable program or batch file.
    ----------------------------

    I searched C:\Windows for files named 'dig' or 'host' but only found similar names, nothing that matched exactly. I am also running a Mac, so if there are similar commands for Mac, I could try to get more info.

    From the 'nslookup,' it would appear that RoadRunner is still processing DNS. 209.18.47.61 corresponds with the Original Time Warner DNS addresses. Not sure where 24.28.193.9 is coming from. However, I have changed the addresses in the router to OpenDNS according to instructions by rotblitz. Should I try restarting the router to ensure changes have taken?!?!?

    Thanks
    • CommentAuthorrotblitz
    • CommentTimeJan 5th 2010 edited
     permalink
    "I searched C:Windows for files named 'dig' or 'host'..."
    Yes, these are for other operating systems, Mac and Linux, not Windows. You didn't state you're using Windows...
    Also, better search for commands in C:\\Windows\\system32 or with the command 'where'.

    "I don't know about proxies."
    This is configured in your browser, e.g. for Internet Explorer:
    Tools > Internet Options > Connections > LAN Settings > Proxy server
    Is a proxy configured in your browser?

    "From the 'nslookup,' it would appear that RoadRunner is still processing DNS."
    You got it! Ah, Roadrunner, you didn't mention either. Use the search function of the forum here to search for Roadrunner in comments, and you will see...

    Let's see if Roadrunner is forcing redirection of your DNS queries to their DNS servers.
    In Windows' command prompt window enter:
    nslookup -type=txt which.opendns.com. 208.67.222.222
    What does this command come back with?

    Also, post the output of "ipconfig /all" here.
    Thankful People: wolfshollywood
  2.  permalink
    No proxy used in Firefox. Actually I just assumed those were Windows commands, probably wasn't reading closely enough. I use the Mac primarily, so here are the commands run on the Mac.

    -----------------
    dig:
    ; <<>> DiG 9.4.3-P3 <<>> myip.opendns.com
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 8255
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;myip.opendns.com. IN A

    ;; ANSWER SECTION:
    myip.opendns.com. 10 IN A 24.28.193.9

    ;; Query time: 76 msec
    ;; SERVER: 76.85.229.110#53(76.85.229.110)
    ;; WHEN: Tue Jan 5 11:23:36 2010
    ;; MSG SIZE rcvd: 66

    -----------------
    host:
    myip.opendns.com has address 24.28.193.9
    Host myip.opendns.com not found: 3(NXDOMAIN)
    Host myip.opendns.com not found: 3(NXDOMAIN)

    -----------------

    It'll take a minute to get the info back from the Windows machine, much easier to use Mac commands, sorry for the confusion. And thanks for the help.
    • CommentAuthorrotblitz
    • CommentTimeJan 5th 2010
     permalink
    These commands were wrong and don't discover anything. The correct one for dig:
    dig +noall +answer which.opendns.com txt @208.67.222.222
    Thankful People: wolfshollywood
  3.  permalink
    dig +noall +answer which.opendns.com txt @208.67.222.222

    which.opendns.com. 0 IN TXT "4.pao"

    -------

    Does that mean anything?
  4.  permalink
    C:\Documents and Settings\User>ipconfig /all

    Windows IP Configuration

    Host Name . . . . . . . . . . . . : usercomputer
    Primary Dns Suffix . . . . . . . :
    Node Type . . . . . . . . . . . . : Broadcast
    IP Routing Enabled. . . . . . . . : No
    WINS Proxy Enabled. . . . . . . . : No
    DNS Suffix Search List. . . . . . : linksys.com

    Ethernet adapter Local Area Connection:

    Connection-specific DNS Suffix . : linksys.com
    Description . . . . . . . . . . . : Broadcom NetXtreme 57xx Gigabit Cont
    roller
    Physical Address. . . . . . . . . : 00-18-8B-05-44-06
    Dhcp Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    IP Address. . . . . . . . . . . . : 192.168.55.231
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Default Gateway . . . . . . . . . : 192.168.55.1
    DHCP Server . . . . . . . . . . . : 192.168.55.1
    DNS Servers . . . . . . . . . . . : 209.18.47.61
    209.18.47.62
    Lease Obtained. . . . . . . . . . : Monday, January 04, 2010 10:50:04 AM

    Lease Expires . . . . . . . . . . : Monday, January 11, 2010 9:30:04 AM

    PPP adapter The Internet (2):

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : WAN (PPP/SLIP) Interface
    Physical Address. . . . . . . . . : 00-53-45-00-00-00
    Dhcp Enabled. . . . . . . . . . . : No
    IP Address. . . . . . . . . . . . : 172.190.80.247
    Subnet Mask . . . . . . . . . . . : 255.255.255.255
    Default Gateway . . . . . . . . . :
    DNS Servers . . . . . . . . . . . : 205.188.146.145
    NetBIOS over Tcpip. . . . . . . . : Disabled
    • CommentAuthordiacon
    • CommentTimeJan 5th 2010 edited
     permalink
    Your DNS settings on the computers should be the router's address and it isn't. You need to configure the DHCP Server in the router to provide itself as the DNS server.

    Also check to make sure that there isn't a static DNS address put in on the computer's network card.
    Thankful People: wolfshollywood
  5.  permalink
    Not quite sure what you mean or how to check a static IP on a network card. Most computer's Ethernet connection is set to auto DHCP, unless you set static.

    I have the router sending out static IPs to individual computers on the network based on MAC address. I manually corrected the DNS server on the Mac(system prefs>network) to be the router's address. Is this wrong? I also manually input a static IP for the Mac on the Mac end as well(redundant).

    I set the DNS servers on a windows box as well and ran ipconfig /all again and verified that the DNS server under the Ethernet section is the same as the DHCP Server.
    • CommentAuthorrotblitz
    • CommentTimeJan 5th 2010 edited
     permalink
    @wolfshollywood
    >>dig +noall +answer which.opendns.com txt @208.67.222.222
    which.opendns.com. 0 IN TXT "4.pao"<<
    Brilliant, you CAN use OpenDNS, although you don't yet. You're using the Palo Alto OpenDNS server location.

    "DNS Servers . . . . . . . . . . . : 209.18.47.61
                                          209.18.47.62"
    This is where your ISP DNS settings are coming from, @diacon is right.
    Try if it works if you remove these entries and replace the first one by 192.168.55.1, which is your router's address.
    If these come from your router, go to http://ui.linksys.com/files/RV042/1.2.3/dhcp_setup.htm and enter 192.168.55.1 as DNS Server 1.

    "DNS Suffix Search List. . . . . . : linksys.com
    Connection-specific DNS Suffix . : linksys.com"
    Try to remove these DNS suffixes, they are of no use and can cause troubles. Look also on the router, if you detect linksys.com somewhere in the configuration.

    Regarding your Mac, you may need to look into /etc/resolv.conf. Sorry, I'm not Mac expert.

    Edit: Oops, this was overlapping with your last message. I was working a while on the response...
    Thankful People: wolfshollywood
  6.  permalink
    IT'S UP AND RUNNING, YEEEAAAHHH!

    Must have been the DNS settings on the individual computers. I'm still curious to know how or why those settings were there. I know I didn't set them, did the router? Or is Time Warner meddling with our computers!!! Wouldn't surprise me...

    Now I just need to manually adjust the settings for each computer on the network.

    Thanks againto you both for all your help I learned some things in the process, and the issue was resolved.
    • CommentAuthorrotblitz
    • CommentTimeJan 5th 2010
     permalink
    Great! Glad to hear that it works for you. Enjoy!
    And yes, I would think it was the router in some way, or its preconfiguration, in case you got it from your ISP. So, it may come up again, and you may try the things from above you didn't try yet.
    Thankful People: wolfshollywood

This discussion has been inactive for longer than 30 days, and is thus closed.