Your IP:

Our Forums Have Moved!

Visit our new forums at https://community.opendns.com/forums/ to post on topics and read the latest content. These forums are now read-only archives.

K-12 Forums

Talk with other K-12 network administrators in your state.

Or see all states.

Categories

Vanilla 1.1.4 is a product of Lussumo. More Information: Documentation, Community Support.

This discussion has been inactive for longer than 30 days, and is thus closed.
    • CommentAuthorglen4cindy
    • CommentTimeSep 29th 2010
     permalink
    Hello. Been running tomato for at least 3 years now without any issues, and I don't ever want to go back to standard Linksys firmware. I was having some slight issues with my router so I updated it to Tomato 1.28, and it worked fine for a few days, until one day I got 0.0.0.0 for an IP address. If I rebooted the cable modem, I would get 192.168.100.10 for about 1 or 2 minutes, and then it would revert to 0.0.0.0.

    I didn't investigate further, and assumed my router had went bad, so I bought another WRT54G v3 on E-Bay and hooked it up, made sure it worked, and was surfing, and using it just fine under Linksys firmware. I might add that I also use OpenDNS, and I don't know if that has any part in this equation or not, but, I am thinking that it might.

    After I made sure the router was working, I loaded Tomato 1.28 on there, and began adding my settings as I like them, one of them being OpenDNS servers. Shortly after, I ended up with 0.0.0.0 as my IP address, even after rebooting the cable modem 3x.

    After this happened, I went into the router settings and replicated the MAC address from my PC, reset the DNS to 0.0.0.0 so the router would get it's DNS from Charter, and now, I am surfing just fine, on 1.28 with the "new" router.

    Is it possible that Charter is "blacklisting" my routers MAC due to my using OpenDNS? Since I have replicated my PC's MAC address in the router, I am afraid of setting up the OpenDNS servers again, just in case this is happening. I don't want my PC's NIC to be black listed because if my internet ever goes down, Charter makes me bypass the router and plug directly in to my PC.

    Any idea why I would get all zeros like this?
  1.  permalink
    First: Nothing to do with using OpenDNS.

    Some ISP's (and their modems) only expect one MAC address to which to assign an IP. The ISP expects only to see the modem's MAC, and the modem expects only to see the "main computer's" MAC. Cloning the MAC from the PC to the router fixes this, and it is why this featre is available in router firmware.

    Why did this change suddenly? Not sure, but a power outage or fluctuation can scramble stored data in routers and modems. Powering them off for a minute can clear this. Also, if the router or modem had been reset, the "expected" MAC may have changed. (Not the actual MAC, just the "expectation".)
    • CommentAuthorglen4cindy
    • CommentTimeSep 29th 2010
     permalink
    No, I understand this is not an OpenDNS issue. This is certainly CHARTER that is FORCING their DNS. I reflashed Linksys firmware back on the router, and was able to put OpenDNS into two of the DNS slots, and Charter filled the 3rd. When I tried to fill the 3rd with and OpenDNS IP, my IP went to 0.0.0.0, so the is certainly CHARTER FORCING me to use THEIR DNS over OpenDNS. I am not happy about this, and I use OpenDNS for it's protection against porn and malware and all the rest of what it protects against, and now, there is apparently no way for me to do this. The Linksys firmware does not have all the features I need, so I really need to use the Tomato firmware that I was using, but, when I use Tomato, Charter's modem will not give me an IP! This should be against the law!
    Thankful People: cc2
    • CommentAuthorrotblitz
    • CommentTimeSep 29th 2010
     permalink
    Well, you can try to configure OpenDNS on the computer instead. This should work.
    https://store.opendns.com/setup/computer/
    Thankful People: OpenDNS User
    • CommentAuthorglen4cindy
    • CommentTimeSep 29th 2010
     permalink
    Thanks, rotblitz, but, the problem with that approach, is, I want every computer that uses my network to have the OpenDNS protections and restrictions placed upon it. We often have people visit from out of town. I would not be able to program the OpenDNS settings in their computer to enforce my network settings, so it has to function on the router. I need to find a way to get around Charter's restrictions, and use my freedom of choice, OpenDNS.
    Thankful People: cc2
  2.  permalink
    "I would not be able to program the OpenDNS settings in their computer to enforce my network settings, so it has to function on the router."

    2 things. One: Is it really nice to enforce your personal restrictions upon other people? Sure, it is your network, but where is the harm? Two: All such a person has to do is configure (if it is not already thus) any other public DNS servers in their TCP/IP settings to bypass this, unless you can block port 53. Then there are only 7,999 other ways for anyone with admin rights on their own computer to bypass this.
    Thankful People: rotblitz
    • CommentAuthorrotblitz
    • CommentTimeSep 29th 2010
     permalink
    So, you got a Linksys WRT54G v3 with the latest Linksys firmware, right? And what exactly is your modem, any link to an online manual? We could take a look then to see what may be possible.
    • CommentAuthorglen4cindy
    • CommentTimeSep 29th 2010
     permalink
    To maintenance: Yes, you are right, it is my network. And when my brother-in-law brings his church group up, I don't want to be in a position where I am providing access to things they should not be looking at. I find it very hard to believe this is the position of maintenance here. You seem to be in disagreement with one of the main functions of OpenDNS.

    I am also the one to decide what my children do and do not look at. If this is the attitude of OpenDNS, then why provide filtering in the first place? Isn't OpenDNS giving us as consumers, and managers of our own networks the freedom to choose what goes on over our networks?

    I also manage the network at my church, and we use OpenDNS. Our pastor does not want people to use the church network for porn or other such things. We keep the password locked down, but, things get out, and people may get access to the password.

    Sure, there are ways around the blocks, but, the casual users I deal with don't know how to manage around the blocks anyway.
    Thankful People: skeeterfish, cc2
  3.  permalink
    "You seem to be in disagreement with one of the main functions of OpenDNS."

    Not really. I simply asked if you thought it appropriate to be filtering the internet on the computers of *adult guests*. This must be one really interesting church group.
    Thankful People: rotblitz
    • CommentAuthorrotblitz
    • CommentTimeSep 29th 2010
     permalink
    @glen4cindy
    "why provide filtering in the first place?"

    No, you missed the point. This is *not* filtering they provide "in the first place". This is the recursive DNS service instead, reliable, stable, and secure, foremost and generally. This other "first place" is *your* favorite only.

    @All
    What was the topic? : "Charter not allowing OpenDNS???"
    What is it now? : "Adult church group keen on viewing p0rn, but church not allowing it" :wink:

    So now, how do we continue, if at all? What about my previous question about the modem details?
    • CommentAuthorzelus
    • CommentTimeSep 29th 2010 edited
     permalink
    Regarding your modem, you *may* be able to configure it to use OpenDNS over your ISP. Some modems are configurable with Telnet if there's no nice GUI to use.

    You should really contact Charter and ask if they are purposefully restricting which DNS resolvers you may use. In some cases, upon request, ISP subscribers are moved over to different subnets that don't have the same restrictions.
    •  
      CommentAuthordavidu
    • CommentTimeSep 29th 2010
     permalink
    Administrator
    Charter does not block OpenDNS... maybe I missed the issue in this thread, but that much I know.
    • CommentAuthorglen4cindy
    • CommentTimeSep 30th 2010
     permalink
    Ok, this is getting out of hand, first off, I'm not talking about adults from a church, I'm talking about youth. Youth who will try to push things if they can, and everyone is curious, so if they can get a look, they might try.

    I also don't want my children and family landing on porn by accident either by going to whitehouse.com instead of whitehouse.gov for example.

    And the reason I couldn't provide modem details is because I was at work and posting comments on lunch and break, and didn't have the modem in front of me. The modem is a Model U10C018 Ambit modem.

    Zelus, when I called Charter, the phone tech I spoke to told me that it has always been "impossoible" for us users to select our own DNS because the DNS is controlled by the modem and Charter has exclusive control over it. Since he obviously does not know what he's talking about, he was of no help to me.

    Davidu, what is your evidence that Charter does not block it? Seems like me trying to set OpenDNS in my router and getting 0.0.0.0, and allowing DHCP DNS and getting my 97.x..x.x IP from Charter is proof that something strange is happening with DNS. I've read evidence of other ISP's doing the same thing, it's evident on Google, so, unless you live in my Charter market, and use OpenDNS, I hardly think you are qulaified to make such a comment.

    I'm just trying to use the **same** configuration that has worked flawlessly for 3 years. Nothing on my side has changed. I have tried a different router, but, what are the chances of two routers behaving exactly the same way? Something Charter is doing has changed. It changed overnight one Saturday night about 2 weeks ago. Ever since then, setting OpenDNS servers in the routers DNS settings causes the modem to give 0.0.0.0 as the IP, subnet mask, default gateway, all parameters usually provided by the modem are all 0.0.0.0. If I let DHCP go free, I get my valid IP, subnet mask, default gateway, and Charter's DNS servers.

    Something on Charter's side has to have changed.
    • CommentAuthorglen4cindy
    • CommentTimeSep 30th 2010
     permalink
    Also, from this part of the OpenDNS website: http://www.opendns.com/start/best_practices/#content_filtering


    "Filtering adult content and other unwanted sites on a network is one of the greatest advantages to using OpenDNS. With a free account, you can manage your network(s) in the Dashboard, setting custom preferences all the way down to the individual public IP address."
    • CommentAuthorrotblitz
    • CommentTimeSep 30th 2010
     permalink
    So, your equipment is connected as follows?
    Computers -- Router -- Charter-Modem -- Internet

    If so, configure the OpenDNS server addresses on the router. Charter has no power over this.

    Btw, @davidu is the CEO of OpenDNS, one of the most experienced people around DNS in the world at all. Therefore your comment "I hardly think you are qulaified to make such a comment" is more than inappropriate, to say it diplomatically. And nobody said that Charter blocks you from using OpenDNS, only you. Charter may however block you from changing the DNS settings on your modem, so change it somewhere else.

    "I'm talking about youth. Youth who will try to push things if they can, and everyone is curious, so if they can get a look, they might try."

    Did you ever ask yourself as to why they might be doing so?
  4.  permalink
    Actually, most modems (that I'm aware of anyway) can't have the DNS changed. Typically you'd change the DNS on a router, PC or server, not your modem.
    • CommentAuthorglen4cindy
    • CommentTimeSep 30th 2010
     permalink
    Thanks rotblitz, I did have the OpenDNS server programmed into the router. When I did this, I got 0.0.0.0 for an IP, when I let it DHCP, I got my valid 97.x.x.x IP.

    Here is an example where this has happened at least once before, so apparently, somehow, it is possible for Charter to keep a user from using their own DNS.

    http://forums.opendns.com/comments.php?DiscussionID=795
  5.  permalink
    "When I did this, I got 0.0.0.0 for an IP"

    This rather more sounds like you are setting "Static IP" on the device in a DHCP environment. Make sure you are only setting DNS to static.
    • CommentAuthorrotblitz
    • CommentTimeSep 30th 2010 edited
     permalink
    @glen4cindy
    You did it wrong. You have a Linksys WRT54G v3, yes? You can't set DNS server addresses on the WAN side, if you've got a dynamic IP address. You have to configure it on the LAN side therefore, all three slots.
    http://ui.linksys.com/files/WRT54G/v1-v4/3.01.3/
    Additional addresses: http://www.opendns.com/support/article/197

    This will cause the OpenDNS server addresses to be propagated via DHCP to the devices behind the router with the disadvantage that you lose local name resolution, which may not be a problem if you don't use it.

    And really, Charter has no way to force anything regarding your router. You simply did it wrong...
    • CommentAuthorglen4cindy
    • CommentTimeSep 30th 2010
     permalink
    I did not set the DNS up on the WAN side.

    I only entered the OpenDNS numbers in the Static DNS areas of the router.

    When I filled all 3 slots with OpenDNS numbers, my Charter IP went to 0.0.0.0, when I went back and took them out, and let DHCP assign them, in other words, left the Static DNS entries blank, the Charter IP repopulated with a 97.x.x.x valid IP address. I know what I saw. I'm not sure why it happened, and I cannot explain it, and if I listen to the Charter tech that I spoke to on the phone, DNS cannot be changed by the end customer at all. I know he's wrong, becuase up till now, I have done it 24-7 for over 3 years. My only question is, why now, since nothing in the configuration has changed, has it stopped working? I could not have "done it wrong" if it was working for over 3 years.
    • CommentAuthorrotblitz
    • CommentTimeOct 1st 2010
     permalink
    I see, we ran out of ideas. This is nothing to do with OpenDNS, but with Charter...
    • CommentAuthorzeldas7777
    • CommentTimeOct 13th 2010
     permalink
    :cool: it is confirmed that charter force dns on consumers. The test was done with modem and router or home security router like smoothwall or ipfire will still get dns from charter. i have manually hard coded the open dns ips in the ip protocol setup to fix the issue. the second test was modem and router on dsl line with at&t i manually enter my dns ip leave wins blank not using file share server over the internet. i only get my manually entered dns. when hooked up to charter a 3rd dns pops up at the bottom of my specified dns ip addresses after connecting to charter.
    Thankful People: zelus
  6.  permalink
    Fill the third address slot:
    http://www.opendns.com/support/article/197
    Thankful People: zelus, OpenDNS User
    • CommentAuthoruncleray
    • CommentTimeOct 14th 2010
     permalink
    glen4cindy how did you access the ambit modem? Even when you use 192.168.100.1 to get into the ambit modem the modem doesn't allow you to change any of the settings
    • CommentAuthoruncleray
    • CommentTimeOct 14th 2010
     permalink
    you need to ditch the charter supplied modem for a linksys......charter supplied modemsrouters are supplied with software they want on them and are Not configurable....im running into a similar problem but with setting up a security system involving cameras and being able to view from my phone....finding that i need a linksys router with port forwarding thats configurable

This discussion has been inactive for longer than 30 days, and is thus closed.